kernel: NFSD: add dependency kmod-crypto-arc4 for kmod-fs-nfs-common-rpcsec
authorRuixi Zhou <zhouruixi@gmail.com>
Sat, 5 Oct 2019 10:16:33 +0000 (18:16 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 12 Oct 2019 21:51:08 +0000 (23:51 +0200)
crypto-arc4 move into a module with commit c3a78955f34a61d402044f357f54f21c75a19ff9,
fs-nfs-common-rpcsec compile error without arc4 support.

Ref: https://github.com/openwrt/packages/issues/9912

Fixes: c3a78955f34a ("kernel: move crypto-arc4 into a module")
Signed-off-by: Ruixi Zhou <zhouruixi@gmail.com>
package/kernel/linux/modules/fs.mk

index 47170058b2f81be4626c74b3ed870ede071937d1..3ffe82cbe8e5fdf4bd4488d3809bb33307a33919 100644 (file)
@@ -389,7 +389,8 @@ define KernelPackage/fs-nfs-common-rpcsec
        +kmod-crypto-md5 \
        +kmod-crypto-sha1 \
        +kmod-crypto-hmac \
-       +kmod-crypto-ecb
+       +kmod-crypto-ecb \
+       +kmod-crypto-arc4
   KCONFIG:= \
        CONFIG_SUNRPC_GSS \
        CONFIG_RPCSEC_GSS_KRB5