rules.mk: export TMPDIR
authorJo-Philipp Wich <jo@mein.io>
Tue, 12 Dec 2017 15:28:04 +0000 (16:28 +0100)
committerJo-Philipp Wich <jo@mein.io>
Wed, 13 Dec 2017 15:57:17 +0000 (16:57 +0100)
Set TMPDIR to the same value as the existing TMP_DIR variable in order to
let gcc and various other utilities use the local temporary directory
instead of the system-wide one.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
(cherry picked from commit 52a3477ff91a2009e451d5dce307e9cc945e9ffa)

rules.mk

index 743619ecff550b4c11afb7ea91c98bcd917bf252..5710a84fe7ad24e45acb2ef62ee29eab37e8de06 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -21,6 +21,7 @@ DUMP:=1
 endif
 
 export TMP_DIR:=$(TOPDIR)/tmp
+export TMPDIR:=$(TMP_DIR)
 
 qstrip=$(strip $(subst ",,$(1)))
 #"))