include: remove file before overwritting it with replace_script
authorJohn Crispin <john@openwrt.org>
Mon, 15 Sep 2014 10:18:56 +0000 (10:18 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 15 Sep 2014 10:18:56 +0000 (10:18 +0000)
config.{sub,guess} could be symlinks to a shared common version of
this file (e.g. in staging). So we remove the destination file via
--remove-destination option of cp. This prevents replaceing the
common file that other packages could be build with if running at
the same time.

This fixes a class of errors where config.sub is missing, or
only partially present when running configure because a cp is
currently in progress

This is commonly seen building with a lot of parallel jobs and
on packages that use 'PKG_FIXUP:=autoreconf'

Signed-off-by: Matthew McClintock <mmcclint@qca.qualcomm.com>
Signed-off-by: Mathieu Olivari <mathieu@qca.qualcomm.com>
SVN-Revision: 42547

include/package-defaults.mk

index 61e495f50f201235e5e1d935b9014fa82d713858..051cde5020a545cd23f95a662885eafe5c1d1fd2 100644 (file)
@@ -98,7 +98,9 @@ CONFIGURE_VARS = \
 CONFIGURE_PATH = .
 CONFIGURE_CMD = ./configure
 
 CONFIGURE_PATH = .
 CONFIGURE_CMD = ./configure
 
-replace_script=$(FIND) $(1) -name $(2) | $(XARGS) chmod u+w; $(FIND) $(1) -name $(2) | $(XARGS) -n1 cp $(SCRIPT_DIR)/$(2);
+replace_script=$(FIND) $(1) -name $(2) | $(XARGS) chmod u+w; \
+              $(FIND) $(1) -name $(2) | $(XARGS) -n1 cp --remove-destination \
+              $(SCRIPT_DIR)/$(2);
 
 define Build/Configure/Default
        (cd $(PKG_BUILD_DIR)/$(CONFIGURE_PATH)/$(strip $(3)); \
 
 define Build/Configure/Default
        (cd $(PKG_BUILD_DIR)/$(CONFIGURE_PATH)/$(strip $(3)); \