kernel: enable SND_COMPRESS_OFFLOAD for kernels >= 3.3
authorFlorian Fainelli <florian@openwrt.org>
Sun, 17 Mar 2013 19:46:00 +0000 (19:46 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 17 Mar 2013 19:46:00 +0000 (19:46 +0000)
Most sound SoC driver enable it and rely it on to properly work.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 36072

package/kernel/modules/sound.mk

index 877d31ba0ff0c776a3482121c2f4028ecae317da..494394603bedf21f5ba0ff80dc6e7c0a98ebe242 100644 (file)
@@ -32,6 +32,14 @@ SOUNDCORE_FILES ?= \
        $(LINUX_DIR)/sound/core/oss/snd-mixer-oss.ko \
        $(LINUX_DIR)/sound/core/oss/snd-pcm-oss.ko
 
        $(LINUX_DIR)/sound/core/oss/snd-mixer-oss.ko \
        $(LINUX_DIR)/sound/core/oss/snd-pcm-oss.ko
 
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3.0)),1)
+SOUNDCORE_LOAD += \
+       snd-compress
+
+SOUNDCORE_FILES += \
+       $(LINUX_DIR)/sound/core/snd-compress.ko
+endif
+
 define KernelPackage/sound-core
   SUBMENU:=$(SOUND_MENU)
   TITLE:=Sound support
 define KernelPackage/sound-core
   SUBMENU:=$(SOUND_MENU)
   TITLE:=Sound support
@@ -50,7 +58,8 @@ define KernelPackage/sound-core
        CONFIG_HOSTAUDIO \
        CONFIG_SND_PCM_OSS \
        CONFIG_SND_MIXER_OSS \
        CONFIG_HOSTAUDIO \
        CONFIG_SND_PCM_OSS \
        CONFIG_SND_MIXER_OSS \
-       CONFIG_SOUND_OSS_CORE_PRECLAIM=y
+       CONFIG_SOUND_OSS_CORE_PRECLAIM=y \
+       CONFIG_SND_COMPRESS_OFFLOAD
   FILES:=$(SOUNDCORE_FILES)
   AUTOLOAD:=$(call AutoLoad,30,$(SOUNDCORE_LOAD))
   $(call AddDepends/input)
   FILES:=$(SOUNDCORE_FILES)
   AUTOLOAD:=$(call AutoLoad,30,$(SOUNDCORE_LOAD))
   $(call AddDepends/input)