always build sed, some systems have a broken one where it's hard to detect
authorFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 22:29:46 +0000 (22:29 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 22:29:46 +0000 (22:29 +0000)
SVN-Revision: 5043

openwrt/tools/sed/Makefile
openwrt/tools/sed/sedcheck.sh [deleted file]

index b3169918b4ff959dc9629adddac0838a97694d2b..61c7acbb007eb9a5a700a3b244928033550f0bd8 100644 (file)
@@ -16,29 +16,23 @@ PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(TOOL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
-HOST_SED_TARGET=$(strip $(shell ./sedcheck.sh))
-
-ifneq ($(HOST_SED_TARGET),build-sed-host-binary)
-  PKG_SOURCE:=
-  PKG_CAT:=
-endif
-
 include $(INCLUDE_DIR)/host-build.mk
 
-ifeq ($(HOST_SED_TARGET),build-sed-host-binary)
-  define Build/Configure
+override SHELL:=$(BASH)
+
+define Build/Configure
        (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
                ./configure \
                --prefix=$(STAGING_DIR) \
                --prefix=/usr \
        );
-  endef
+endef
 
-  define Build/Compile
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)
-  endef
+endef
 
-  define Build/Install
+define Build/Install
        @if [ -L $(STAGING_DIR)/bin/sed ] ; then \
                rm -f $(STAGING_DIR)/bin/sed; fi;
        @if [ ! -f $(STAGING_DIR)/bin/sed -o $(STAGING_DIR)/bin/sed -ot $(PKG_BUILD_DIR)/sed/sed ]; then \
@@ -49,15 +43,6 @@ ifeq ($(HOST_SED_TARGET),build-sed-host-binary)
            rm -rf $(STAGING_DIR)/share/locale $(STAGING_DIR)/usr/info \
                    $(STAGING_DIR)/usr/man $(STAGING_DIR)/usr/share/doc; \
        fi
-  endef
-else
-  define Build/Compile
-  endef
-  define Build/Install
-    rm -rf $(STAGING_DIR)/bin/sed
-       mkdir -p $(STAGING_DIR)/bin
-       ln -s `which sed` $(STAGING_DIR)/bin/sed
-  endef
-endif
+endef
 
 $(eval $(call HostBuild))
diff --git a/openwrt/tools/sed/sedcheck.sh b/openwrt/tools/sed/sedcheck.sh
deleted file mode 100755 (executable)
index f5a09fd..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/sh
-
-if [ -x /usr/bin/sed ]; then 
-    SED="/usr/bin/sed";
-else
-    if [ -x /bin/sed ]; then 
-       SED="/bin/sed";
-    fi;
-fi;
-
-echo "HELLO" > .sedtest
-$SED -i -e "s/HELLO/GOODBYE/" .sedtest >/dev/null 2>&1
-
-case "$1" in
-       *)
-               if [ $? != 0 ] ; then
-                       echo build-sed-host-binary
-               else
-                       echo use-sed-host-binary
-               fi;
-       ;;
-esac
-rm -f .sedtest*
-