mkimage: update to 2013.04
authorLuka Perkov <luka@openwrt.org>
Sun, 5 May 2013 20:11:04 +0000 (20:11 +0000)
committerLuka Perkov <luka@openwrt.org>
Sun, 5 May 2013 20:11:04 +0000 (20:11 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 36550

tools/mkimage/Makefile
tools/mkimage/patches/010-freebsd-ulong-fix.patch
tools/mkimage/patches/020-openbsd_fixes.patch
tools/mkimage/patches/030-allow-to-use-different-magic.patch
tools/mkimage/patches/040-include_order.patch [deleted file]
tools/mkimage/patches/100-dtc-binary.patch [new file with mode: 0644]

index 7bd7316537e2b8d03cd2397f046417a18eff160f..458cca8fe527a9106b755ece385d46ef414879ab 100644 (file)
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mkimage
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mkimage
-PKG_VERSION:=2013.01.01
+PKG_VERSION:=2013.04
 
 PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
 
 PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=73939f78606f89a1775c7e9acb2ca617
+PKG_MD5SUM:=21bf962d69938ed4ed783b792b2b074e
 PKG_CAT:=bzcat
 
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
 PKG_CAT:=bzcat
 
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
index 737291466c57ecf9c15e612fda380b3a8094c65b..715755b875c901d3c3f15c32714c8271d67c141c 100644 (file)
@@ -9,5 +9,5 @@
 +#endif
 +
  #if defined(CONFIG_FIT)
 +#endif
 +
  #if defined(CONFIG_FIT)
- #include <fdt.h>
  #include <libfdt.h>
  #include <libfdt.h>
+ #include <fdt_support.h>
index 17232360d2c2594f89bd2da453041b0f7f616560..4c376caadd6ac20a248c58600fd1acb9738592ff 100644 (file)
@@ -1,6 +1,6 @@
 --- a/tools/mkimage.c
 +++ b/tools/mkimage.c
 --- a/tools/mkimage.c
 +++ b/tools/mkimage.c
-@@ -464,6 +464,7 @@
+@@ -464,6 +464,7 @@ NXTARG:            ;
  #if defined(_POSIX_SYNCHRONIZED_IO) && \
     !defined(__sun__) && \
     !defined(__FreeBSD__) && \
  #if defined(_POSIX_SYNCHRONIZED_IO) && \
     !defined(__sun__) && \
     !defined(__FreeBSD__) && \
@@ -8,7 +8,7 @@
     !defined(__APPLE__)
        (void) fdatasync (ifd);
  #else
     !defined(__APPLE__)
        (void) fdatasync (ifd);
  #else
-@@ -507,6 +508,7 @@
+@@ -507,6 +508,7 @@ NXTARG:            ;
  #if defined(_POSIX_SYNCHRONIZED_IO) && \
     !defined(__sun__) && \
     !defined(__FreeBSD__) && \
  #if defined(_POSIX_SYNCHRONIZED_IO) && \
     !defined(__sun__) && \
     !defined(__FreeBSD__) && \
index 305b8342b3d0401465bf5053bca3e9cc9f6b3dc8..14397964b6d86904d074c1e2c522463eb6243adb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/tools/mkimage.c
 +++ b/tools/mkimage.c
 --- a/tools/mkimage.c
 +++ b/tools/mkimage.c
-@@ -37,6 +37,7 @@
+@@ -37,6 +37,7 @@ struct mkimage_params params = {
        .arch = IH_ARCH_PPC,
        .type = IH_TYPE_KERNEL,
        .comp = IH_COMP_GZIP,
        .arch = IH_ARCH_PPC,
        .type = IH_TYPE_KERNEL,
        .comp = IH_COMP_GZIP,
@@ -8,7 +8,7 @@
        .dtc = MKIMAGE_DEFAULT_DTC_OPTIONS,
        .imagename = "",
        .imagename2 = "",
        .dtc = MKIMAGE_DEFAULT_DTC_OPTIONS,
        .imagename = "",
        .imagename2 = "",
-@@ -189,6 +190,16 @@
+@@ -189,6 +190,16 @@ main (int argc, char **argv)
                                        genimg_get_comp_id (*++argv)) < 0)
                                        usage ();
                                goto NXTARG;
                                        genimg_get_comp_id (*++argv)) < 0)
                                        usage ();
                                goto NXTARG;
@@ -25,7 +25,7 @@
                        case 'D':
                                if (--argc <= 0)
                                        usage ();
                        case 'D':
                                if (--argc <= 0)
                                        usage ();
-@@ -613,12 +624,13 @@
+@@ -613,12 +624,13 @@ usage ()
        fprintf (stderr, "Usage: %s -l image\n"
                         "          -l ==> list image header information\n",
                params.cmdname);
        fprintf (stderr, "Usage: %s -l image\n"
                         "          -l ==> list image header information\n",
                params.cmdname);
@@ -42,7 +42,7 @@
                         "          -n ==> set image name to 'name'\n"
 --- a/tools/mkimage.h
 +++ b/tools/mkimage.h
                         "          -n ==> set image name to 'name'\n"
 --- a/tools/mkimage.h
 +++ b/tools/mkimage.h
-@@ -65,6 +65,7 @@
+@@ -65,6 +65,7 @@ struct mkimage_params {
        int arch;
        int type;
        int comp;
        int arch;
        int type;
        int comp;
@@ -52,7 +52,7 @@
        unsigned int ep;
 --- a/tools/default_image.c
 +++ b/tools/default_image.c
        unsigned int ep;
 --- a/tools/default_image.c
 +++ b/tools/default_image.c
-@@ -111,7 +111,7 @@
+@@ -111,7 +111,7 @@ static void image_set_header(void *ptr,
                        sbuf->st_size - sizeof(image_header_t));
  
        /* Build new header */
                        sbuf->st_size - sizeof(image_header_t));
  
        /* Build new header */
diff --git a/tools/mkimage/patches/040-include_order.patch b/tools/mkimage/patches/040-include_order.patch
deleted file mode 100644 (file)
index f94e91d..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/tools/Makefile
-+++ b/tools/Makefile
-@@ -162,9 +162,9 @@
- # Use native tools and options
- # Define __KERNEL_STRICT_NAMES to prevent typedef overlaps
- #
--HOSTCPPFLAGS =        -idirafter $(SRCTREE)/include \
-+HOSTCPPFLAGS =        -I $(SRCTREE)/include \
-               -idirafter $(OBJTREE)/include2 \
--              -idirafter $(OBJTREE)/include \
-+              -I $(OBJTREE)/include \
-               -I $(SRCTREE)/lib/libfdt \
-               -I $(SRCTREE)/tools \
-               -DCONFIG_SYS_TEXT_BASE=$(CONFIG_SYS_TEXT_BASE) \
diff --git a/tools/mkimage/patches/100-dtc-binary.patch b/tools/mkimage/patches/100-dtc-binary.patch
new file mode 100644 (file)
index 0000000..5034119
--- /dev/null
@@ -0,0 +1,86 @@
+--- a/doc/mkimage.1
++++ b/doc/mkimage.1
+@@ -82,6 +82,10 @@
+ .B Create FIT image:
+ .TP
++.BI "\-B [" "dtc bin" "]"
++Set path to the device tree compiler binary.
++
++.TP
+ .BI "\-D [" "dtc options" "]"
+ Provide special options to the device tree compiler that is used to
+ create the image.
+--- a/tools/fit_image.c
++++ b/tools/fit_image.c
+@@ -82,7 +82,8 @@
+       /* dtc -I dts -O dtb -p 500 datafile > tmpfile */
+       sprintf (cmd, "%s %s %s > %s",
+-              MKIMAGE_DTC, params->dtc, params->datafile, tmpfile);
++              params->dtc_bin, params->dtc_options, params->datafile,
++              tmpfile);
+       debug ("Trying to execute \"%s\"\n", cmd);
+       if (system (cmd) == -1) {
+               fprintf (stderr, "%s: system(%s) failed: %s\n",
+--- a/tools/mkimage.c
++++ b/tools/mkimage.c
+@@ -38,7 +38,8 @@
+       .type = IH_TYPE_KERNEL,
+       .comp = IH_COMP_GZIP,
+       .magic = IH_MAGIC,
+-      .dtc = MKIMAGE_DEFAULT_DTC_OPTIONS,
++      .dtc_bin = MKIMAGE_DTC,
++      .dtc_options = MKIMAGE_DEFAULT_DTC_OPTIONS,
+       .imagename = "",
+       .imagename2 = "",
+ };
+@@ -200,10 +201,15 @@
+                                               params.cmdname, *argv);
+                               }
+                               goto NXTARG;
++                      case 'B':
++                              if (--argc <= 0)
++                                      usage ();
++                              params.dtc_bin = *++argv;
++                              goto NXTARG;
+                       case 'D':
+                               if (--argc <= 0)
+                                       usage ();
+-                              params.dtc = *++argv;
++                              params.dtc_options = *++argv;
+                               goto NXTARG;
+                       case 'O':
+@@ -637,7 +643,9 @@
+                        "          -d ==> use image data from 'datafile'\n"
+                        "          -x ==> set XIP (execute in place)\n",
+               params.cmdname);
+-      fprintf (stderr, "       %s [-D dtc_options] -f fit-image.its fit-image\n",
++      fprintf (stderr, "       %s [-B dtc_bin] [-D dtc_options] -f fit-image.its fit-image\n",
++                       "           -B ==> set path to the dtc binary\n",
++                       "           -D ==> set options that will be passed to dtc\n",
+               params.cmdname);
+       fprintf (stderr, "       %s -V ==> print version information and exit\n",
+               params.cmdname);
+--- a/tools/mkimage.h
++++ b/tools/mkimage.h
+@@ -46,7 +46,7 @@
+ #define MKIMAGE_MAX_TMPFILE_LEN               256
+ #define MKIMAGE_DEFAULT_DTC_OPTIONS   "-I dts -O dtb -p 500"
+ #define MKIMAGE_MAX_DTC_CMDLINE_LEN   512
+-#define MKIMAGE_DTC                   "dtc"   /* assume dtc is in $PATH */
++#define MKIMAGE_DTC                   "dtc"
+ /*
+  * This structure defines all such variables those are initialized by
+@@ -66,7 +66,8 @@
+       int type;
+       int comp;
+       unsigned int magic;
+-      char *dtc;
++      char *dtc_bin;
++      char *dtc_options;
+       unsigned int addr;
+       unsigned int ep;
+       char *imagename;