ramips/mt76x8: add initramfs support for tplink 841n v13
authorAlexander Couzens <lynxis@fe80.eu>
Mon, 9 Oct 2017 11:51:21 +0000 (13:51 +0200)
committerAlexander Couzens <lynxis@fe80.eu>
Mon, 9 Oct 2017 15:34:41 +0000 (17:34 +0200)
The tplink 841n v13 requires an tplink v2 image header in
front of an initramfs image.

To boot an initramfs image:
- break the uboot by holding the '4' key
- setup your tftp server 192.168.0.255
- tftp 81000000 lede-ramips-mt76x8-tl-wr841n-v13-initramfs-kernel.bin
- bootm

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
target/linux/ramips/image/mt76x8.mk

index db32684f7d15ccb6899364084a6772c174f1a4b1..56da7b104908e5f764e93ea5805c3a27e03f89d0 100644 (file)
@@ -91,6 +91,7 @@ define Device/tl-wr840n-v4
   TPLINK_HWREVADD := 0x4
   TPLINK_HVERSION := 3
   KERNEL := $(KERNEL_DTB)
   TPLINK_HWREVADD := 0x4
   TPLINK_HVERSION := 3
   KERNEL := $(KERNEL_DTB)
+  KERNEL_INITRAMFS := $(KERNEL_DTB) | tplink-v2-header -e
   IMAGES += tftp-recovery.bin
   IMAGE/factory.bin := tplink-v2-image -e
   IMAGE/tftp-recovery.bin := pad-extra 128k | $$(IMAGE/factory.bin)
   IMAGES += tftp-recovery.bin
   IMAGE/factory.bin := tplink-v2-image -e
   IMAGE/tftp-recovery.bin := pad-extra 128k | $$(IMAGE/factory.bin)