kernel: update 3.14 to 3.14.28
authorLuka Perkov <luka@openwrt.org>
Sun, 11 Jan 2015 01:28:32 +0000 (01:28 +0000)
committerLuka Perkov <luka@openwrt.org>
Sun, 11 Jan 2015 01:28:32 +0000 (01:28 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 43929

include/kernel-version.mk
target/linux/generic/patches-3.14/100-overlayfs.patch
target/linux/generic/patches-3.14/941-ocf_20120127.patch
target/linux/imx6/patches-3.14/0002-ARM-dts-added-several-new-imx-pinmux-groups.patch
target/linux/imx6/patches-3.14/204-net-igb-register-mii_bus-for-SerDes-w-external-phy.patch
target/linux/imx6/patches-3.14/205-phy-add-driver-for-GW16083-Ethernet-Expansion-Mezzan.patch

index 856d8755fb41ef3c0a4a3a27467fcf06c72d88a7..0881938d998767b053ee28548a5fe83da27d7244 100644 (file)
@@ -6,14 +6,14 @@ LINUX_VERSION-3.3  = .8
 LINUX_VERSION-3.8  = .13
 LINUX_VERSION-3.10 = .58
 LINUX_VERSION-3.13 = .7
-LINUX_VERSION-3.14 = .27
+LINUX_VERSION-3.14 = .28
 LINUX_VERSION-3.18 = .2
 
 LINUX_KERNEL_MD5SUM-3.3.8   = f1058f64eed085deb44f10cee8541d50
 LINUX_KERNEL_MD5SUM-3.8.13  = 2af19d06cd47ec459519159cdd10542d
 LINUX_KERNEL_MD5SUM-3.10.58 = 3ff3478b6351143cef22d4b81cf48b01
 LINUX_KERNEL_MD5SUM-3.13.7  = 370adced5e5c1cb1d0d621c2dae2723f
-LINUX_KERNEL_MD5SUM-3.14.27 = 0af2d0702df6ee6d7181e697e0af3481
+LINUX_KERNEL_MD5SUM-3.14.28 = 3fd2be486a6348808a1f6a637d7eab8e
 LINUX_KERNEL_MD5SUM-3.18.2  = 7b28d5543cf3647d2483830af19f3770
 
 ifdef KERNEL_PATCHVER
index a04b1fefca4c946bf8fbf8682d447d64c0ffc96a..bbf23a7a5dcef52a0306b77d230d05435647a50f 100644 (file)
  obj-$(CONFIG_OMFS_FS)         += omfs/
 --- a/fs/ecryptfs/main.c
 +++ b/fs/ecryptfs/main.c
-@@ -566,6 +566,13 @@ static struct dentry *ecryptfs_mount(str
+@@ -576,6 +576,13 @@ static struct dentry *ecryptfs_mount(str
        s->s_maxbytes = path.dentry->d_sb->s_maxbytes;
        s->s_blocksize = path.dentry->d_sb->s_blocksize;
        s->s_magic = ECRYPTFS_SUPER_MAGIC;
                goto out;
 --- a/fs/namespace.c
 +++ b/fs/namespace.c
-@@ -1581,6 +1581,33 @@ void drop_collected_mounts(struct vfsmou
+@@ -1586,6 +1586,33 @@ void drop_collected_mounts(struct vfsmou
        namespace_unlock();
  }
  
index b8b1eed9bd568b8a3aa60ea4c2b3956529dc5e9b..b744026cb1917095c0ea814a3679f1cd63fa3ace 100644 (file)
  void generate_random_uuid(unsigned char uuid_out[16]);
 --- a/kernel/pid.c
 +++ b/kernel/pid.c
-@@ -425,6 +425,7 @@ void transfer_pid(struct task_struct *ol
+@@ -427,6 +427,7 @@ void transfer_pid(struct task_struct *ol
        new->pids[type].pid = old->pids[type].pid;
        hlist_replace_rcu(&old->pids[type].node, &new->pids[type].node);
  }
index c93662a420bcd40e9ee086740180a179b3e701f9..f2d7f6ca17ce856409dfa2852ca4c31a5b736756 100644 (file)
@@ -97,10 +97,11 @@ Signed-off-by: Shawn Guo <shawn.guo@linaro.org>
                                };
  
                                uart4 {
-@@ -1107,6 +1158,15 @@
+@@ -1106,6 +1157,15 @@
+                                               >;
                                        };
                                };
++
 +                              uart5 {
 +                                      pinctrl_uart5_1: uart5grp-1 {
 +                                              fsl,pins = <
@@ -109,7 +110,6 @@ Signed-off-by: Shawn Guo <shawn.guo@linaro.org>
 +                                              >;
 +                                      };
 +                              };
-+
                                usbotg {
                                        pinctrl_usbotg_1: usbotggrp-1 {
-                                               fsl,pins = <
index ab26601bfc71b7cbc9a7aa45e18a8ce32bc043cc..0bcbbd7bc3d21a654da9b5db6dd259e42cf757bd 100644 (file)
@@ -89,7 +89,7 @@ Date:   Thu May 15 12:36:23 2014 -0700
  #include <linux/delay.h>
  #include <linux/interrupt.h>
  #include <linux/ip.h>
-@@ -2189,6 +2190,126 @@ static s32 igb_init_i2c(struct igb_adapt
+@@ -2191,6 +2192,126 @@ static s32 igb_init_i2c(struct igb_adapt
        return status;
  }
  
@@ -216,7 +216,7 @@ Date:   Thu May 15 12:36:23 2014 -0700
  /**
   *  igb_probe - Device Initialization Routine
   *  @pdev: PCI device information struct
-@@ -2591,6 +2712,13 @@ static int igb_probe(struct pci_dev *pde
+@@ -2593,6 +2714,13 @@ static int igb_probe(struct pci_dev *pde
        }
  
        pm_runtime_put_noidle(&pdev->dev);
@@ -230,7 +230,7 @@ Date:   Thu May 15 12:36:23 2014 -0700
        return 0;
  
  err_register:
-@@ -2734,6 +2862,10 @@ static void igb_remove(struct pci_dev *p
+@@ -2736,6 +2864,10 @@ static void igb_remove(struct pci_dev *p
        struct e1000_hw *hw = &adapter->hw;
  
        pm_runtime_get_noresume(&pdev->dev);
@@ -241,7 +241,7 @@ Date:   Thu May 15 12:36:23 2014 -0700
  #ifdef CONFIG_IGB_HWMON
        igb_sysfs_exit(adapter);
  #endif
-@@ -3038,6 +3170,12 @@ static int __igb_open(struct net_device 
+@@ -3040,6 +3172,12 @@ static int __igb_open(struct net_device
        if (!resuming)
                pm_runtime_put(&pdev->dev);
  
@@ -254,7 +254,7 @@ Date:   Thu May 15 12:36:23 2014 -0700
        /* start the watchdog. */
        hw->mac.get_link_status = 1;
        schedule_work(&adapter->watchdog_task);
-@@ -7093,21 +7231,41 @@ void igb_alloc_rx_buffers(struct igb_rin
+@@ -7095,21 +7233,41 @@ void igb_alloc_rx_buffers(struct igb_rin
  static int igb_mii_ioctl(struct net_device *netdev, struct ifreq *ifr, int cmd)
  {
        struct igb_adapter *adapter = netdev_priv(netdev);
index cf46434daa238ab794bd658083b204310d1f0e76..1350d5a0bba50eb2b7796e005fe82720e7a9098b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -278,6 +278,14 @@ endif # RTL8366_SMI
+@@ -273,6 +273,14 @@ endif # RTL8366_SMI
  
  source "drivers/net/phy/b53/Kconfig"
  
@@ -17,7 +17,7 @@
  config MICREL_KS8995MA
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -40,6 +40,7 @@ obj-$(CONFIG_NATIONAL_PHY)   += national.o
+@@ -39,6 +39,7 @@ obj-$(CONFIG_NATIONAL_PHY)   += national.o
  obj-$(CONFIG_DP83640_PHY)     += dp83640.o
  obj-$(CONFIG_STE10XP)         += ste10Xp.o
  obj-$(CONFIG_MICREL_PHY)      += micrel.o