package/dnsmasq: add max_ttl/min_cache_ttl/max_cache_ttl
authorAlexander Couzens <lynxis@fe80.eu>
Wed, 20 Feb 2019 17:09:50 +0000 (18:09 +0100)
committerAlexander Couzens <lynxis@fe80.eu>
Sun, 24 Feb 2019 00:48:25 +0000 (01:48 +0100)
max_ttl - limit the ttl in the dns answer if greater as $max_ttl
min_cache_ttl - force caching of dns answers even the ttl in the answer
is lower than the $min_cache_ttl
max_cache_ttl - cache only dns answer for $max_cache_ttl.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
package/network/services/dnsmasq/Makefile
package/network/services/dnsmasq/files/dnsmasq.init

index 8c8427f6c175aefd0e44e38c25d28751cad6ca4f..1710ded5f88ed1e0b46a8ae2d37f553a91d4bf23 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=dnsmasq
 PKG_UPSTREAM_VERSION:=2.80
 PKG_VERSION:=$(subst test,~~test,$(subst rc,~rc,$(PKG_UPSTREAM_VERSION)))
 PKG_NAME:=dnsmasq
 PKG_UPSTREAM_VERSION:=2.80
 PKG_VERSION:=$(subst test,~~test,$(subst rc,~rc,$(PKG_UPSTREAM_VERSION)))
-PKG_RELEASE:=10
+PKG_RELEASE:=11
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_UPSTREAM_VERSION).tar.xz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_UPSTREAM_VERSION).tar.xz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
index 4ae71e438bec8faa428edaa6af625f1ebf0c3f50..93a8f9a108092bba17fbbae90c9dfaf02478fcc1 100644 (file)
@@ -860,6 +860,9 @@ dnsmasq_start()
        append_parm "$cfg" "tftp_root" "--tftp-root"
        append_parm "$cfg" "dhcp_boot" "--dhcp-boot"
        append_parm "$cfg" "local_ttl" "--local-ttl"
        append_parm "$cfg" "tftp_root" "--tftp-root"
        append_parm "$cfg" "dhcp_boot" "--dhcp-boot"
        append_parm "$cfg" "local_ttl" "--local-ttl"
+       append_parm "$cfg" "max_ttl" "--max-ttl"
+       append_parm "$cfg" "min_cache_ttl" "--min-cache-ttl"
+       append_parm "$cfg" "max_cache_ttl" "--max-cache-ttl"
        append_parm "$cfg" "pxe_prompt" "--pxe-prompt"
        config_list_foreach "$cfg" "pxe_service" append_pxe_service
        config_get DOMAIN "$cfg" domain
        append_parm "$cfg" "pxe_prompt" "--pxe-prompt"
        config_list_foreach "$cfg" "pxe_service" append_pxe_service
        config_get DOMAIN "$cfg" domain