kernel: update 3.18 to 3.18.6
authorLuka Perkov <luka@openwrt.org>
Sun, 8 Feb 2015 12:01:37 +0000 (12:01 +0000)
committerLuka Perkov <luka@openwrt.org>
Sun, 8 Feb 2015 12:01:37 +0000 (12:01 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 44318

include/kernel-version.mk
target/linux/generic/patches-3.18/431-mtd-bcm47xxpart-support-for-Xiaomi-specific-board_da.patch
target/linux/generic/patches-3.18/432-mtd-bcm47xxpart-detect-T_Meter-partition.patch
target/linux/generic/patches-3.18/653-disable_netlink_trim.patch
target/linux/generic/patches-3.18/721-phy_packets.patch
target/linux/generic/patches-3.18/811-pci_disable_usb_common_quirks.patch
target/linux/generic/patches-3.18/834-ledtrig-libata.patch
target/linux/generic/patches-3.18/902-debloat_proc.patch

index cd282888b1fe93845a397a0e3f592785e604dd99..cc07d3d05d8f47a4530d83414167079e335d40c9 100644 (file)
@@ -6,14 +6,14 @@ LINUX_VERSION-3.8  = .13
 LINUX_VERSION-3.10 = .58
 LINUX_VERSION-3.13 = .7
 LINUX_VERSION-3.14 = .32
-LINUX_VERSION-3.18 = .5
+LINUX_VERSION-3.18 = .6
 LINUX_VERSION-3.19 = -rc5
 
 LINUX_KERNEL_MD5SUM-3.8.13  = 2af19d06cd47ec459519159cdd10542d
 LINUX_KERNEL_MD5SUM-3.10.58 = 3ff3478b6351143cef22d4b81cf48b01
 LINUX_KERNEL_MD5SUM-3.13.7  = 370adced5e5c1cb1d0d621c2dae2723f
 LINUX_KERNEL_MD5SUM-3.14.32 = 3178fb8f6f1eafcffdd730fec68754f8
-LINUX_KERNEL_MD5SUM-3.18.5  = b655fcbc4597aa4b0cbabcfc72983259
+LINUX_KERNEL_MD5SUM-3.18.6  = 997c8492ebfdc9bb9e6ed8d4945539dd
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index a7b17533de2389068d198d9cf684246997fe5cfc..a30e698b898fc23a1cc045f3bae56f54764d773f 100644 (file)
@@ -12,8 +12,6 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
  drivers/mtd/bcm47xxpart.c | 4 +++-
  1 file changed, 3 insertions(+), 1 deletion(-)
 
-diff --git a/drivers/mtd/bcm47xxpart.c b/drivers/mtd/bcm47xxpart.c
-index c0720c1..f14ec0f 100644
 --- a/drivers/mtd/bcm47xxpart.c
 +++ b/drivers/mtd/bcm47xxpart.c
 @@ -33,6 +33,7 @@
@@ -24,7 +22,7 @@ index c0720c1..f14ec0f 100644
  #define CFE_MAGIC                     0x43464531      /* 1EFC */
  #define FACTORY_MAGIC                 0x59544346      /* FCTY */
  #define NVRAM_HEADER                  0x48534C46      /* FLSH */
-@@ -262,7 +263,8 @@ static int bcm47xxpart_parse(struct mtd_info *master,
+@@ -262,7 +263,8 @@ static int bcm47xxpart_parse(struct mtd_
                }
  
                /* Some devices (ex. WNDR3700v3) don't have a standard 'MPFR' */
@@ -34,6 +32,3 @@ index c0720c1..f14ec0f 100644
                        bcm47xxpart_add_part(&parts[curr_part++], "board_data",
                                             offset, MTD_WRITEABLE);
                        continue;
--- 
-1.8.4.5
-
index 3f702259805b7eaa4ceb3d570c934eb15c55e37e..1edc99525dd10c6790d8d99a00664236a6d8cd89 100644 (file)
@@ -14,8 +14,6 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
  drivers/mtd/bcm47xxpart.c | 10 ++++++++++
  1 file changed, 10 insertions(+)
 
-diff --git a/drivers/mtd/bcm47xxpart.c b/drivers/mtd/bcm47xxpart.c
-index f14ec0f..40dd0db 100644
 --- a/drivers/mtd/bcm47xxpart.c
 +++ b/drivers/mtd/bcm47xxpart.c
 @@ -39,6 +39,7 @@
@@ -26,10 +24,11 @@ index f14ec0f..40dd0db 100644
  #define ML_MAGIC1                     0x39685a42
  #define ML_MAGIC2                     0x26594131
  #define TRX_MAGIC                     0x30524448
-@@ -177,6 +178,15 @@ static int bcm47xxpart_parse(struct mtd_info *master,
+@@ -176,6 +177,15 @@ static int bcm47xxpart_parse(struct mtd_
+                                            MTD_WRITEABLE);
                        continue;
                }
++
 +              /* T_Meter */
 +              if ((le32_to_cpu(buf[0x000 / 4]) & 0xFFFF0000) == T_METER_MAGIC &&
 +                  (le32_to_cpu(buf[0x030 / 4]) & 0xFFFF0000) == T_METER_MAGIC &&
@@ -38,10 +37,6 @@ index f14ec0f..40dd0db 100644
 +                                           MTD_WRITEABLE);
 +                      continue;
 +              }
-+
                /* TRX */
                if (buf[0x000 / 4] == TRX_MAGIC) {
-                       if (BCM47XXPART_MAX_PARTS - curr_part < 4) {
--- 
-1.8.4.5
-
index 6b25a2e8f5a8cb9a03b2a9ae3983ee35ed4fda0c..5732596792912ff7fd6d24633110dc69e1b08700 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/netlink/af_netlink.c
 +++ b/net/netlink/af_netlink.c
-@@ -1715,27 +1715,7 @@ void netlink_detachskb(struct sock *sk,
+@@ -1695,27 +1695,7 @@ void netlink_detachskb(struct sock *sk,
  
  static struct sk_buff *netlink_trim(struct sk_buff *skb, gfp_t allocation)
  {
index 0e21ff30809d7a5a661d06ab2dd794471a4dbb5e..5d989741a6a1fbd42138f8ee405fbb56d8958195 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -1216,6 +1216,7 @@ enum netdev_priv_flags {
+@@ -1220,6 +1220,7 @@ enum netdev_priv_flags {
        IFF_LIVE_ADDR_CHANGE            = 1<<20,
        IFF_MACVLAN                     = 1<<21,
        IFF_XMIT_DST_RELEASE_PERM       = 1<<22,
@@ -8,7 +8,7 @@
  };
  
  #define IFF_802_1Q_VLAN                       IFF_802_1Q_VLAN
-@@ -1241,6 +1242,7 @@ enum netdev_priv_flags {
+@@ -1245,6 +1246,7 @@ enum netdev_priv_flags {
  #define IFF_LIVE_ADDR_CHANGE          IFF_LIVE_ADDR_CHANGE
  #define IFF_MACVLAN                   IFF_MACVLAN
  #define IFF_XMIT_DST_RELEASE_PERM     IFF_XMIT_DST_RELEASE_PERM
@@ -16,7 +16,7 @@
  
  /**
   *    struct net_device - The DEVICE structure.
-@@ -1511,6 +1513,11 @@ struct net_device {
+@@ -1515,6 +1517,11 @@ struct net_device {
        const struct ethtool_ops *ethtool_ops;
        const struct forwarding_accel_ops *fwd_ops;
  
@@ -28,7 +28,7 @@
        const struct header_ops *header_ops;
  
        unsigned int            flags;
-@@ -1573,6 +1580,10 @@ struct net_device {
+@@ -1577,6 +1584,10 @@ struct net_device {
        void                    *ax25_ptr;
        struct wireless_dev     *ieee80211_ptr;
  
@@ -86,7 +86,7 @@
        help
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -2607,10 +2607,20 @@ static int xmit_one(struct sk_buff *skb,
+@@ -2623,10 +2623,20 @@ static int xmit_one(struct sk_buff *skb,
        if (!list_empty(&ptype_all))
                dev_queue_xmit_nit(skb, dev);
  
index 9cc6df0f50e97da4fe2c0fcbc16fec5a31c574e6..d4099fa94cc5da97889835970d66aee7b269c0e2 100644 (file)
@@ -39,7 +39,7 @@
  static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
  {
        u16 cmd;
-@@ -1083,3 +1098,4 @@ static void quirk_usb_early_handoff(stru
+@@ -1095,3 +1110,4 @@ static void quirk_usb_early_handoff(stru
  }
  DECLARE_PCI_FIXUP_CLASS_FINAL(PCI_ANY_ID, PCI_ANY_ID,
                        PCI_CLASS_SERIAL_USB, 8, quirk_usb_early_handoff);
index cfe92d9a025d64301ba0d95344205fd9b0708eec..52dab409d75d9bde39b14c25f4f4758e31d0f9cc 100644 (file)
@@ -69,7 +69,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -4753,6 +4766,9 @@ static struct ata_queued_cmd *ata_qc_new
+@@ -4756,6 +4769,9 @@ static struct ata_queued_cmd *ata_qc_new
                        break;
                }
        }
@@ -79,7 +79,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        return qc;
  }
-@@ -5663,6 +5679,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -5666,6 +5682,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -89,7 +89,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -5684,6 +5703,12 @@ static void ata_host_release(struct devi
+@@ -5687,6 +5706,12 @@ static void ata_host_release(struct devi
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -102,7 +102,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6130,7 +6155,23 @@ int ata_host_register(struct ata_host *h
+@@ -6133,7 +6158,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
@@ -138,7 +138,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
  /*
   * Define if arch has non-standard setup.  This is a _PCI_ standard
-@@ -861,6 +864,12 @@ struct ata_port {
+@@ -862,6 +865,12 @@ struct ata_port {
  #ifdef CONFIG_ATA_ACPI
        struct ata_acpi_gtm     __acpi_init_gtm; /* use ata_acpi_init_gtm() */
  #endif
index 1134b83d49e2605d7addaa6d8f1055752b58e3dc..929d6e5ba934ede2fb955c5df503818c7f9577a8 100644 (file)
@@ -79,7 +79,7 @@
  }
 --- a/kernel/irq/proc.c
 +++ b/kernel/irq/proc.c
-@@ -311,6 +311,9 @@ void register_irq_proc(unsigned int irq,
+@@ -328,6 +328,9 @@ void register_irq_proc(unsigned int irq,
  {
        char name [MAX_NAMELEN];
  
@@ -89,7 +89,7 @@
        if (!root_irq_dir || (desc->irq_data.chip == &no_irq_chip) || desc->dir)
                return;
  
-@@ -347,6 +350,9 @@ void unregister_irq_proc(unsigned int ir
+@@ -364,6 +367,9 @@ void unregister_irq_proc(unsigned int ir
  {
        char name [MAX_NAMELEN];
  
@@ -99,7 +99,7 @@
        if (!root_irq_dir || !desc->dir)
                return;
  #ifdef CONFIG_SMP
-@@ -382,6 +388,9 @@ void init_irq_proc(void)
+@@ -399,6 +405,9 @@ void init_irq_proc(void)
        unsigned int irq;
        struct irq_desc *desc;