oxnas: copy ubinized images to binary folder
authorJohn Crispin <john@openwrt.org>
Mon, 9 Feb 2015 12:16:04 +0000 (12:16 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 9 Feb 2015 12:16:04 +0000 (12:16 +0000)
Since r43778 ubinized images are stored inside KDIR. This makes sense
when using an uninized image to generate a factory image.
On oxnas ubinized images were used for sysupgrade before proper NAND
support was implemented in OpenWrt.
For users still on old builds before sysupgrade.tar was introduced,
ubinized image is thus the only option to conveniantly upgrade to a
more recent build.
Copy ubinized image also to BIN_DIR, so it will be easier for users
to find them.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
SVN-Revision: 44357

target/linux/oxnas/image/Makefile

index a3dae16f7627c4df0cc88599dec1c0d08d09191d..b09c67ef36e83eb1d4d61a80273169546ffad0ec 100644 (file)
@@ -89,6 +89,7 @@ endef
 define Image/Build/squashfs
        $(call Image/Build/SysupgradeNAND,$(call sanitize_profile_name),$(1),$(KDIR)/fit-$(call sanitize_profile_name).itb)
        $(call Image/Build/UbinizeImage,$(call sanitize_profile_name),--uboot-env --kernel $(KDIR)/fit-$(call sanitize_profile_name).itb,$(1),$($(PROFILE)_UBI_OPTS))
+       cp $(KDIR)/$(IMG_PREFIX)-$(call sanitize_profile_name)-squashfs-ubinized.bin $(BIN_DIR)
 endef
 
 define Image/mkfs/targz
@@ -101,6 +102,7 @@ define Image/Build/ubifs
  ifneq ($($(PROFILE)_UBIFS_OPTS),)
        $(call Image/Build/SysupgradeNAND,$(call sanitize_profile_name),ubifs,$(KDIR)/fit-$(call sanitize_profile_name).itb)
        $(call Image/Build/UbinizeImage,$(call sanitize_profile_name),--uboot-env --kernel $(KDIR)/fit-$(call sanitize_profile_name).itb,ubifs,$($(PROFILE)_UBI_OPTS))
+       cp $(KDIR)/$(IMG_PREFIX)-$(call sanitize_profile_name)-ubifs-ubinized.bin $(BIN_DIR)
  endif
 
 endef