ar71xx: nbg6716: Enable procd nand sysupgrage
authorJohn Crispin <john@openwrt.org>
Thu, 26 Jun 2014 11:43:38 +0000 (11:43 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 26 Jun 2014 11:43:38 +0000 (11:43 +0000)
This enables the procd nand upgrade for ZyXEL NBG 6716. Also the ubi config
is cleaned up to match the wndr4300.

Signed-off-by: André Valentin <avalentin@marcant.net>
SVN-Revision: 41346

target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/image/Makefile
target/linux/ar71xx/image/ubinize-nbg6716.ini

index 57803ccd9dbef3553d1c526f42c14ff5a42abd2e..c98737436ba153765e06be892f643e736a44857c 100755 (executable)
@@ -305,6 +305,7 @@ platform_check_image() {
                }
                return 0
                ;;
+       nbg6716 | \
        wndr4300 )
                nand_do_platform_check $board $1
                return $?;
index 877a7611963d62c0a9fe7cc3022682045fc3265d..abc8b667e0b0b621d5a3612583c50a2ab2700a66 100644 (file)
@@ -923,7 +923,6 @@ define Image/Build/ZyXELNAND
        $(eval kernelsize=$(call mtdpartsize,kernel,$(4)))
        $(eval imageraw=$(KDIR_TMP)/$(2)-raw.img)
        $(CP) $(KDIR)/root.$(1) $(KDIR_TMP)/ubi_root.img
-       echo -ne '\xde\xad\xc0\xde' > $(KDIR_TMP)/jffs2.eof
        $(call ubinize,ubinize-$(2).ini,$(KDIR_TMP),$(KDIR_TMP)/$(2)-root.ubi,128KiB,2048,-E 5)
        ( \
                dd if=$(KDIR_TMP)/$(2)-kernel.jffs2; \
@@ -931,10 +930,7 @@ define Image/Build/ZyXELNAND
        ) > $(imageraw)
        dd if=$(imageraw) of=$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1)-factory.bin \
                bs=128k conv=sync
-       ( \
-               dd if=$(KDIR_TMP)/$(2)-kernel.jffs2; \
-               dd if=$(KDIR)/root.$(1) bs=128k conv=sync \
-       ) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1)-sysupgrade.bin
+       $(call Image/Build/SysupgradeNAND,$(2),squashfs,$(KDIR_TMP)/$(2)-kernel.jffs2)
 endef
 
 
index ec8d7c7fc60057d64fff4e4df9eb23fb95cf56bc..814b0fbcc8629233df949dbe4c82e8f499658528 100644 (file)
@@ -9,15 +9,10 @@ vol_id=0
 vol_type=dynamic
 # Volume name
 vol_name=rootfs
-# Autoresize volume at first mount
-# vol_flags=autoresize
-vol_size=40MiB
 
 [rootfs_data]
 # Volume mode (other option is static)
 mode=ubi
-# Source image
-image=jffs2.eof
 # Volume ID in UBI image
 vol_id=1
 # Allow for dynamic resize
@@ -25,5 +20,5 @@ vol_type=dynamic
 # Volume name
 vol_name=rootfs_data
 # Autoresize volume at first mount
-vol_size=100MiB
-#vol_flags=autoresize
+vol_size=1MiB
+vol_flags=autoresize