hostapd: stop advertising 11w feature
authorDobroslaw Kijowski <dobo90@gmail.com>
Sun, 3 Jan 2021 12:46:21 +0000 (13:46 +0100)
committerPaul Spooren <mail@aparcar.org>
Mon, 21 Jun 2021 00:11:30 +0000 (14:11 -1000)
This is a follow up of 1a9b896d ("treewide: nuke DRIVER_11W_SUPPORT").
LuCI commit ab010406 ("luci-mod-network: skip check for 802.11w feature")
skips check of the 11w feature [1]. Now advertising it in hostapd is
superfluous so stop doing it.

[1]: https://github.com/openwrt/luci/pull/4689

Signed-off-by: Dobroslaw Kijowski <dobo90@gmail.com>
[remove outdated PKG_RELEASE bump and update to SPDX]
Signed-off-by: Paul Spooren <mail@aparcar.org>
package/network/services/hostapd/Makefile
package/network/services/hostapd/src/src/utils/build_features.h

index 3c521b485dcb83ccd435362e174d4a66ee015e30..fee6889b40820e10f08acffe014fb817502a364f 100644 (file)
@@ -1,8 +1,6 @@
-# Copyright (C) 2006-2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
+# SPDX-License-Identifier: GPL-2.0-only
 #
+# Copyright (C) 2006-2021 OpenWrt.org
 
 include $(TOPDIR)/rules.mk
 
index c7fccad413b8c71795b826ffd1ee1b55e7d06a2c..3ab5246c789f6f81e89e6e3e9a9774fb9e5effe9 100644 (file)
@@ -23,8 +23,6 @@ static inline int has_feature(const char *feat)
        if (!strcmp(feat, "11r"))
                return 1;
 #endif
-       if (!strcmp(feat, "11w"))
-               return 1;
 #ifdef CONFIG_ACS
        if (!strcmp(feat, "acs"))
                return 1;