base-files: dispatch ifdown events for proto=none interfaces and fix a race condition...
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 14 Sep 2009 16:14:27 +0000 (16:14 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 14 Sep 2009 16:14:27 +0000 (16:14 +0000)
SVN-Revision: 17582

package/base-files/Makefile
package/base-files/files/sbin/ifdown

index 4661a5a575eddeca6098f896e7e6b8796606a535..d87253b4dda5c68d42669a4aeceee5dcd1622b14 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=29
+PKG_RELEASE:=30
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index 883f8ec42893bc8c3fb70286a6674f1430deeeac..8de414d8b6dd96ad349b52ffe97e5a398f562fc8 100755 (executable)
@@ -22,8 +22,8 @@ config_get proto "$cfg" proto
 [ -z "$proto" ] && { echo "interface not found."; exit; }
 
 config_get iface "$cfg" device
-[ "static" = "$proto" ] && {
-       env -i ACTION="ifdown" INTERFACE="$cfg" DEVICE="$iface" PROTO=static /sbin/hotplug-call "iface" &
+[ "static" = "$proto" -o "none" = "$proto" ] && {
+       env -i ACTION="ifdown" INTERFACE="$cfg" DEVICE="$iface" PROTO="$proto" /sbin/hotplug-call "iface"
 }
 
 # call interface stop handler