include/kernel-build.mk: fix kernel rebuild on backport patch changes
authorMatthias Schiffer <mschiffer@universe-factory.net>
Sat, 14 Jul 2018 11:07:34 +0000 (13:07 +0200)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Sat, 14 Jul 2018 11:10:08 +0000 (13:10 +0200)
An incorrect variable name was referenced in KERNEL_FILE_DEPENDS, leading
to the omission of the backport-* patch dirs in the generation of the
prepared stamp name.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
(cherry picked from commit 36fa1bbf6f510e57098edab3932015dc747bbd49)

include/kernel-build.mk

index c3658c216ae176ed92f621c742a68573eeb57c3a..b7bcf0e17deb8a963c1cdeb87acaf85baebea68c 100644 (file)
@@ -11,7 +11,7 @@ ifneq ($(DUMP),1)
   all: compile
 endif
 
   all: compile
 endif
 
-KERNEL_FILE_DEPENDS=$(BACKPORT_PATCH_DIR) $(GENERIC_PATCH_DIR) $(GENERIC_HACK_DIR) $(PATCH_DIR) $(GENERIC_FILES_DIR) $(FILES_DIR)
+KERNEL_FILE_DEPENDS=$(GENERIC_BACKPORT_DIR) $(GENERIC_PATCH_DIR) $(GENERIC_HACK_DIR) $(PATCH_DIR) $(GENERIC_FILES_DIR) $(FILES_DIR)
 STAMP_PREPARED=$(LINUX_DIR)/.prepared$(if $(QUILT)$(DUMP),,_$(shell $(call find_md5,$(KERNEL_FILE_DEPENDS),)))
 STAMP_CONFIGURED:=$(LINUX_DIR)/.configured
 include $(INCLUDE_DIR)/download.mk
 STAMP_PREPARED=$(LINUX_DIR)/.prepared$(if $(QUILT)$(DUMP),,_$(shell $(call find_md5,$(KERNEL_FILE_DEPENDS),)))
 STAMP_CONFIGURED:=$(LINUX_DIR)/.configured
 include $(INCLUDE_DIR)/download.mk