build: warn when packages have no associated install section
authorJonas Gorski <jonas.gorski@gmail.com>
Sat, 22 Jun 2019 12:02:27 +0000 (14:02 +0200)
committerJo-Philipp Wich <jo@mein.io>
Wed, 4 Sep 2019 11:21:22 +0000 (13:21 +0200)
Declaring a package without the appropriate install section is an easy
mistake to make, especially when renaming packages. Since this is also
easy to detect, warn about it when it happens.

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
No-objections-at-all-by: Jo-Philipp Wich <jo@mein.io>
(cherry picked from commit 5ede3fcdf74dcc1b1b4c9415152b2e8b26a45ead)

include/package-ipkg.mk

index 38252b95cdb92ae788e0b6f326ae28b77ed272a2..442d3854f046f5795e24d6ad7c5031b083f9e54f 100644 (file)
@@ -124,6 +124,8 @@ ifeq ($(DUMP),)
       endif
       $(PKG_INSTALL_STAMP).$(1): prepare-package-install
                echo "$(1)" >> $(PKG_INSTALL_STAMP)
       endif
       $(PKG_INSTALL_STAMP).$(1): prepare-package-install
                echo "$(1)" >> $(PKG_INSTALL_STAMP)
+    else
+      $(if $(CONFIG_PACKAGE_$(1)),$$(warning WARNING: skipping $(1) -- package has no install section))
     endif
     endif
 
     endif
     endif