prereq-build: fix python distutils detection
authorRosen Penev <rosenp@gmail.com>
Fri, 9 Sep 2022 19:28:08 +0000 (12:28 -0700)
committerChristian Marangi <ansuelsmth@gmail.com>
Sun, 11 Sep 2022 14:12:24 +0000 (16:12 +0200)
Debian and by extension Ubuntu packages distutils in a suboptimal way
where import distutils works but none of the methods do.

This alternative check verifies that distutils is actually usable.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
include/prereq-build.mk

index 0a023c2c6f6eceea40a9fdeaa36db420a43cbced..67993cf7e30ef745cee371344f47237482d48de5 100644 (file)
@@ -188,7 +188,7 @@ $(eval $(call SetupHostCommand,python3,Please install Python >= 3.6, \
 
 $(eval $(call TestHostCommand,python3-distutils, \
        Please install the Python3 distutils module, \
-       $(STAGING_DIR_HOST)/bin/python3 -c 'import distutils'))
+       $(STAGING_DIR_HOST)/bin/python3 -c 'from distutils import util'))
 
 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
        file --version 2>&1 | grep file))