brcm63xx: Use model name for Comtrend AR-5381u
authorJonas Gorski <jogo@openwrt.org>
Sat, 12 Jul 2014 12:31:35 +0000 (12:31 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sat, 12 Jul 2014 12:31:35 +0000 (12:31 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 41587

target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.10/532-board_96328a-1241N.patch [deleted file]
target/linux/brcm63xx/patches-3.10/532-board_AR-5381u.patch [new file with mode: 0644]
target/linux/brcm63xx/patches-3.10/555-board_96318ref.patch
target/linux/brcm63xx/patches-3.14/532-board_96328a-1241N.patch [deleted file]
target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch [new file with mode: 0644]
target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch

index be381c2042d3fb24f22c9b8c3aab1ff39b7c6678..a01606a7a0d3b90f6295ac446508c66470d21516 100755 (executable)
@@ -25,7 +25,7 @@ brcm63xx_detect() {
                ;;
        96328A-1241N)
                brcm63xx_has_reset_button="true"
-               status_led="96328A-1241N:green:power"
+               status_led="AR-5381u:green:power"
                ifname=eth0
                ;;
        96369R-1231N)
index a4108483cc8c4beb4b00d9cb29b0d84444323cb1..11d7678581bcacca57b2c1f0939766c8ad142f2d 100755 (executable)
@@ -168,7 +168,6 @@ define Image/Build
        $(call Image/Build/CFE,$(1),96328avng,6328,96328avng-4M-flash-generic,,--pad 2)
        $(call Image/Build/CFE,$(1),96328avng,6328,96328avng-8M-flash-generic,,--pad 4)
        $(call Image/Build/CFE,$(1),96328avng,6328,96328avng-16M-flash-generic,,--pad 8)
-       $(call Image/Build/CFE,$(1),96328A-1241N,6328,96328A-1241N-generic,,--pad 8)
        $(call Image/Build/CFE,$(1),963281TAN,6328,963281TAN-4M-flash-generic,,--pad 2)
        $(call Image/Build/CFE,$(1),963281TAN,6328,963281TAN-8M-flash-generic,,--pad 4)
        $(call Image/Build/CFE,$(1),963281TAN,6328,963281TAN-16M-flash-generic,,--pad 8)
@@ -227,6 +226,8 @@ define Image/Build
        $(call Image/Build/CFE,$(1),CT6373-1,6358,CT6373)
        # Comtrend 536, 5621
        $(call Image/Build/CFEFIXUP,$(1),96348GW-11,CT536_CT5621,6348,CT536_CT5621)
+       # Comtrend AR-5381u
+       $(call Image/Build/CFE,$(1),96328A-1241N,6328,AR-5381u,,--pad 8)
        # Comtrend AR-5387un
        $(call Image/Build/CFE,$(1),96328A-1441N1,6328,AR-5387un,,--pad 8)
        # Comtrend WAP-5813n
diff --git a/target/linux/brcm63xx/patches-3.10/532-board_96328a-1241N.patch b/target/linux/brcm63xx/patches-3.10/532-board_96328a-1241N.patch
deleted file mode 100644 (file)
index bcbf50a..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
---- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
-+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -165,6 +165,73 @@ static struct board_info __initdata boar
-       },
- };
-+static struct board_info __initdata board_96328A_1241N = {
-+      .name                                   = "96328A-1241N",
-+      .expected_cpu_id                        = 0x6328,
-+
-+      .has_uart0                              = 1,
-+      .has_pci                                = 1,
-+      .has_ohci0                              = 1,
-+      .has_ehci0                              = 1,
-+      .num_usbh_ports                         = 1,
-+      .has_enetsw                             = 1,
-+
-+      .enetsw = {
-+              .used_ports = {
-+                      [0] = {
-+                              .used           = 1,
-+                              .phy_id         = 1,
-+                              .name           = "Port 1",
-+                      },
-+                      [1] = {
-+                              .used           = 1,
-+                              .phy_id         = 2,
-+                              .name           = "Port 2",
-+                      },
-+                      [2] = {
-+                              .used           = 1,
-+                              .phy_id         = 3,
-+                              .name           = "Port 3",
-+                      },
-+                      [3] = {
-+                              .used           = 1,
-+                              .phy_id         = 4,
-+                              .name           = "Port 4",
-+                      },
-+              },
-+      },
-+
-+      .leds = {
-+              {
-+                      .name                   = "96328A-1241N:green:power",
-+                      .gpio                   = 4,
-+                      .active_low             = 1,
-+                      .default_trigger        = "default-on",
-+              },
-+              {
-+                      .name                   = "96328A-1241N:red:alarm",
-+                      .gpio                   = 2,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "96328A-1241N:green:inet",
-+                      .gpio                   = 3,
-+                      .active_low             = 1,
-+              },
-+      },
-+
-+      .buttons = {
-+              {
-+                      .desc                   = "reset",
-+                      .gpio                   = 23,
-+                      .active_low             = 1,
-+                      .type                   = EV_KEY,
-+                      .code                   = KEY_RESTART,
-+                      .debounce_interval      = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
-+              },
-+      },
-+};
-+
- static struct board_info __initdata board_AR5387un = {
-       .name                                   = "96328A-1441N1",
-       .expected_cpu_id                        = 0x6328,
-@@ -3152,6 +3219,7 @@ static const struct board_info __initcon
- #endif
- #ifdef CONFIG_BCM63XX_CPU_6328
-       &board_96328avng,
-+      &board_96328A_1241N,
-       &board_AR5387un,
-       &board_963281TAN,
-       &board_A4001N1,
diff --git a/target/linux/brcm63xx/patches-3.10/532-board_AR-5381u.patch b/target/linux/brcm63xx/patches-3.10/532-board_AR-5381u.patch
new file mode 100644 (file)
index 0000000..5cda917
--- /dev/null
@@ -0,0 +1,84 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -165,6 +165,73 @@ static struct board_info __initdata boar
+       },
+ };
++static struct board_info __initdata board_AR5381u = {
++      .name                                   = "96328A-1241N",
++      .expected_cpu_id                        = 0x6328,
++
++      .has_uart0                              = 1,
++      .has_pci                                = 1,
++      .has_ohci0                              = 1,
++      .has_ehci0                              = 1,
++      .num_usbh_ports                         = 1,
++      .has_enetsw                             = 1,
++
++      .enetsw = {
++              .used_ports = {
++                      [0] = {
++                              .used           = 1,
++                              .phy_id         = 1,
++                              .name           = "Port 1",
++                      },
++                      [1] = {
++                              .used           = 1,
++                              .phy_id         = 2,
++                              .name           = "Port 2",
++                      },
++                      [2] = {
++                              .used           = 1,
++                              .phy_id         = 3,
++                              .name           = "Port 3",
++                      },
++                      [3] = {
++                              .used           = 1,
++                              .phy_id         = 4,
++                              .name           = "Port 4",
++                      },
++              },
++      },
++
++      .leds = {
++              {
++                      .name                   = "AR-5381u:green:power",
++                      .gpio                   = 4,
++                      .active_low             = 1,
++                      .default_trigger        = "default-on",
++              },
++              {
++                      .name                   = "AR-5381u:red:alarm",
++                      .gpio                   = 2,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "AR-5381u:green:inet",
++                      .gpio                   = 3,
++                      .active_low             = 1,
++              },
++      },
++
++      .buttons = {
++              {
++                      .desc                   = "reset",
++                      .gpio                   = 23,
++                      .active_low             = 1,
++                      .type                   = EV_KEY,
++                      .code                   = KEY_RESTART,
++                      .debounce_interval      = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
++              },
++      },
++};
++
+ static struct board_info __initdata board_AR5387un = {
+       .name                                   = "96328A-1441N1",
+       .expected_cpu_id                        = 0x6328,
+@@ -3152,6 +3219,7 @@ static const struct board_info __initcon
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6328
+       &board_96328avng,
++      &board_AR5381u,
+       &board_AR5387un,
+       &board_963281TAN,
+       &board_A4001N1,
index 20cee1c41d847cea085c52440e6c794bc585a8c5..5ba1a2906ee042d46c0e8aa90176665d3c594add 100644 (file)
 +#endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
-       &board_96328A_1241N,
+       &board_AR5381u,
diff --git a/target/linux/brcm63xx/patches-3.14/532-board_96328a-1241N.patch b/target/linux/brcm63xx/patches-3.14/532-board_96328a-1241N.patch
deleted file mode 100644 (file)
index 268acdc..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
---- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
-+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -167,6 +167,73 @@ static struct board_info __initdata boar
-       },
- };
-+static struct board_info __initdata board_96328A_1241N = {
-+      .name                                   = "96328A-1241N",
-+      .expected_cpu_id                        = 0x6328,
-+
-+      .has_uart0                              = 1,
-+      .has_pci                                = 1,
-+      .has_ohci0                              = 1,
-+      .has_ehci0                              = 1,
-+      .num_usbh_ports                         = 1,
-+      .has_enetsw                             = 1,
-+
-+      .enetsw = {
-+              .used_ports = {
-+                      [0] = {
-+                              .used           = 1,
-+                              .phy_id         = 1,
-+                              .name           = "Port 1",
-+                      },
-+                      [1] = {
-+                              .used           = 1,
-+                              .phy_id         = 2,
-+                              .name           = "Port 2",
-+                      },
-+                      [2] = {
-+                              .used           = 1,
-+                              .phy_id         = 3,
-+                              .name           = "Port 3",
-+                      },
-+                      [3] = {
-+                              .used           = 1,
-+                              .phy_id         = 4,
-+                              .name           = "Port 4",
-+                      },
-+              },
-+      },
-+
-+      .leds = {
-+              {
-+                      .name                   = "96328A-1241N:green:power",
-+                      .gpio                   = 4,
-+                      .active_low             = 1,
-+                      .default_trigger        = "default-on",
-+              },
-+              {
-+                      .name                   = "96328A-1241N:red:alarm",
-+                      .gpio                   = 2,
-+                      .active_low             = 1,
-+              },
-+              {
-+                      .name                   = "96328A-1241N:green:inet",
-+                      .gpio                   = 3,
-+                      .active_low             = 1,
-+              },
-+      },
-+
-+      .buttons = {
-+              {
-+                      .desc                   = "reset",
-+                      .gpio                   = 23,
-+                      .active_low             = 1,
-+                      .type                   = EV_KEY,
-+                      .code                   = KEY_RESTART,
-+                      .debounce_interval      = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
-+              },
-+      },
-+};
-+
- static struct board_info __initdata board_AR5387un = {
-       .name                                   = "96328A-1441N1",
-       .expected_cpu_id                        = 0x6328,
-@@ -3162,6 +3229,7 @@ static const struct board_info __initcon
- #endif
- #ifdef CONFIG_BCM63XX_CPU_6328
-       &board_96328avng,
-+      &board_96328A_1241N,
-       &board_AR5387un,
-       &board_963281TAN,
-       &board_A4001N1,
diff --git a/target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch b/target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch
new file mode 100644 (file)
index 0000000..d9bb845
--- /dev/null
@@ -0,0 +1,84 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -167,6 +167,73 @@ static struct board_info __initdata boar
+       },
+ };
++static struct board_info __initdata board_AR5381u = {
++      .name                                   = "96328A-1241N",
++      .expected_cpu_id                        = 0x6328,
++
++      .has_uart0                              = 1,
++      .has_pci                                = 1,
++      .has_ohci0                              = 1,
++      .has_ehci0                              = 1,
++      .num_usbh_ports                         = 1,
++      .has_enetsw                             = 1,
++
++      .enetsw = {
++              .used_ports = {
++                      [0] = {
++                              .used           = 1,
++                              .phy_id         = 1,
++                              .name           = "Port 1",
++                      },
++                      [1] = {
++                              .used           = 1,
++                              .phy_id         = 2,
++                              .name           = "Port 2",
++                      },
++                      [2] = {
++                              .used           = 1,
++                              .phy_id         = 3,
++                              .name           = "Port 3",
++                      },
++                      [3] = {
++                              .used           = 1,
++                              .phy_id         = 4,
++                              .name           = "Port 4",
++                      },
++              },
++      },
++
++      .leds = {
++              {
++                      .name                   = "AR-5381u:green:power",
++                      .gpio                   = 4,
++                      .active_low             = 1,
++                      .default_trigger        = "default-on",
++              },
++              {
++                      .name                   = "AR-5381u:red:alarm",
++                      .gpio                   = 2,
++                      .active_low             = 1,
++              },
++              {
++                      .name                   = "AR-5381u:green:inet",
++                      .gpio                   = 3,
++                      .active_low             = 1,
++              },
++      },
++
++      .buttons = {
++              {
++                      .desc                   = "reset",
++                      .gpio                   = 23,
++                      .active_low             = 1,
++                      .type                   = EV_KEY,
++                      .code                   = KEY_RESTART,
++                      .debounce_interval      = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
++              },
++      },
++};
++
+ static struct board_info __initdata board_AR5387un = {
+       .name                                   = "96328A-1441N1",
+       .expected_cpu_id                        = 0x6328,
+@@ -3162,6 +3229,7 @@ static const struct board_info __initcon
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6328
+       &board_96328avng,
++      &board_AR5381u,
+       &board_AR5387un,
+       &board_963281TAN,
+       &board_A4001N1,
index 52a1e6d3633fa406820c877a62126fa7b372995a..88286d3801dc3c8de24265d86bd08e212d319b85 100644 (file)
 +#endif
  #ifdef CONFIG_BCM63XX_CPU_6328
        &board_96328avng,
-       &board_96328A_1241N,
+       &board_AR5381u,