compile and register SPI controller device
authorFlorian Fainelli <florian@openwrt.org>
Sun, 8 Mar 2009 12:18:26 +0000 (12:18 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 8 Mar 2009 12:18:26 +0000 (12:18 +0000)
SVN-Revision: 14789

target/linux/brcm63xx/files/arch/mips/bcm63xx/Makefile
target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c

index 4f2423c92988b7b11a36b9c0295123960ee9c1a4..c1363895a1ac9adfc1f938559ba676e656dc44dc 100644 (file)
@@ -5,6 +5,7 @@ obj-y           += dev-usb-ohci.o
 obj-y          += dev-usb-ehci.o
 obj-y          += dev-enet.o
 obj-y          += dev-wdt.o
 obj-y          += dev-usb-ehci.o
 obj-y          += dev-enet.o
 obj-y          += dev-wdt.o
+obj-y          += dev-spi.o
 obj-$(CONFIG_EARLY_PRINTK)     += early_printk.o
 
 obj-y          += boards/
 obj-$(CONFIG_EARLY_PRINTK)     += early_printk.o
 
 obj-y          += boards/
index 4323ee2f671ccedee2e538008fb8c7bdace37b58..56da94b8c2b1a5dc59c202c435ac4f66a6f17b9d 100644 (file)
@@ -27,6 +27,7 @@
 #include <bcm63xx_dev_pcmcia.h>
 #include <bcm63xx_dev_usb_ohci.h>
 #include <bcm63xx_dev_usb_ehci.h>
 #include <bcm63xx_dev_pcmcia.h>
 #include <bcm63xx_dev_usb_ohci.h>
 #include <bcm63xx_dev_usb_ehci.h>
+#include <bcm63xx_dev_spi.h>
 #include <board_bcm963xx.h>
 
 #define PFX    "board_bcm963xx: "
 #include <board_bcm963xx.h>
 
 #define PFX    "board_bcm963xx: "
@@ -482,6 +483,7 @@ int __init board_register_devices(void)
 
        bcm63xx_uart_register();
        bcm63xx_wdt_register();
 
        bcm63xx_uart_register();
        bcm63xx_wdt_register();
+       bcm63xx_spi_register();
 
        if (board.has_pccard)
                bcm63xx_pcmcia_register();
 
        if (board.has_pccard)
                bcm63xx_pcmcia_register();