build: do not call initramfs build from within the image builder
authorFelix Fietkau <nbd@openwrt.org>
Fri, 29 May 2015 13:41:31 +0000 (13:41 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 29 May 2015 13:41:31 +0000 (13:41 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 45837

include/image.mk

index 051f0f7e53dd11248b9bba4b1b30aeca656e5fe7..36c6c63320ffc8c9d52161452b808ef445c947b3 100644 (file)
@@ -471,7 +471,7 @@ define BuildImage
 
   kernel_prepare: mkfs_prepare
        $(call Image/BuildKernel)
 
   kernel_prepare: mkfs_prepare
        $(call Image/BuildKernel)
-       $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),$(call Image/BuildKernel/Initramfs))
+       $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),$(if $(IB),,$(call Image/BuildKernel/Initramfs)))
        $(call Image/InstallKernel)
 
   $(foreach device,$(TARGET_DEVICES),$(call Device,$(device)))
        $(call Image/InstallKernel)
 
   $(foreach device,$(TARGET_DEVICES),$(call Device,$(device)))