kernel: bump 4.9 to 4.9.214
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 21 Feb 2020 14:07:19 +0000 (15:07 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 24 Feb 2020 13:21:08 +0000 (14:21 +0100)
Refreshed all patches.

Fixes:
- CVE-2013-1798

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ar71xx/patches-4.9/450-gpio-nxp-74hc153-gpio-chip-driver.patch
target/linux/ar71xx/patches-4.9/451-gpio-74x164-improve-platform-device-support.patch
target/linux/ar71xx/patches-4.9/452-gpio-add-gpio-latch-driver.patch
target/linux/ar71xx/patches-4.9/910-unaligned_access_hacks.patch
target/linux/brcm2708/patches-4.9/950-0090-OF-DT-Overlay-configfs-interface.patch
target/linux/brcm47xx/patches-4.9/209-b44-register-adm-switch.patch
target/linux/brcm47xx/patches-4.9/210-b44_phy_fix.patch
target/linux/layerscape/patches-4.9/817-usb-support-layerscape.patch
target/linux/mpc85xx/patches-4.9/102-powerpc-add-cmdline-override.patch

index 548c1a4a0e6b98aa249dcd1efa70d4cbc68745f4..6ad131a368214e3aa119c08cf992269b4cc990f9 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .212
+LINUX_VERSION-4.9 = .214
 LINUX_VERSION-4.14 = .169
 
 LINUX_VERSION-4.14 = .169
 
-LINUX_KERNEL_HASH-4.9.212 = ade738a606c9b52ecf764e94b4e77116caa3a2b8abd30f4534d220ac6894be30
+LINUX_KERNEL_HASH-4.9.214 = b47f093dac7034c7c4722e80042c05e4ef53c14a4f28aa992117a127d2b1e483
 LINUX_KERNEL_HASH-4.14.169 = d88ea97993c56b1fa0b0a05061bcde476c6be4fc3bb2de8bd97a8f8ff7278249
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 LINUX_KERNEL_HASH-4.14.169 = d88ea97993c56b1fa0b0a05061bcde476c6be4fc3bb2de8bd97a8f8ff7278249
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 30d7b2f6bd0b1c3aad2fbb8f32d584ca271dfa92..c9008adc1bcf79d8f4c253da468ee02824f5dad4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
-@@ -1214,4 +1214,12 @@ config GPIO_VIPERBOARD
+@@ -1215,4 +1215,12 @@ config GPIO_VIPERBOARD
  
  endmenu
  
  
  endmenu
  
index 87cdcc8d080b8dbfd0a455a4794e76c06a352302..11a2196cf4b8978934e0cda4847c4ae8a4567d09 100644 (file)
 +#endif
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
 +#endif
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
-@@ -1155,7 +1155,6 @@ menu "SPI GPIO expanders"
+@@ -1156,7 +1156,6 @@ menu "SPI GPIO expanders"
  
  config GPIO_74X164
        tristate "74x164 serial-in/parallel-out 8-bits shift register"
  
  config GPIO_74X164
        tristate "74x164 serial-in/parallel-out 8-bits shift register"
index feb5ab43a4494821c9fc61abea2d81b1e5bb96a2..98a4885d0240376cd7847813dbbd0eaa2d89150e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
-@@ -1221,4 +1221,9 @@ config GPIO_NXP_74HC153
+@@ -1222,4 +1222,9 @@ config GPIO_NXP_74HC153
          Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
          provides a GPIO interface supporting input mode only.
  
          Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
          provides a GPIO interface supporting input mode only.
  
index 5e03ad32112d76875665a0fd8b5056bab98478aa..37aaf92e6e3a68322d0471ce6afdc24655aeec6d 100644 (file)
   * No flags defined yet.
 --- a/net/core/utils.c
 +++ b/net/core/utils.c
   * No flags defined yet.
 --- a/net/core/utils.c
 +++ b/net/core/utils.c
-@@ -321,8 +321,14 @@ void inet_proto_csum_replace16(__sum16 *
+@@ -338,8 +338,14 @@ void inet_proto_csum_replace16(__sum16 *
                               bool pseudohdr)
  {
        __be32 diff[] = {
                               bool pseudohdr)
  {
        __be32 diff[] = {
index 941047adc5e27b38fec06ce4daea0556f3e9571f..16175d5c5fb45231e7549efb60678baceeab4f8a 100644 (file)
@@ -88,8 +88,8 @@ Signed-off-by: Slawomir Stepien <sst@poczta.fm>
 +make sense for developers (since it avoids problems with namespaces).
 --- a/drivers/of/Kconfig
 +++ b/drivers/of/Kconfig
 +make sense for developers (since it avoids problems with namespaces).
 --- a/drivers/of/Kconfig
 +++ b/drivers/of/Kconfig
-@@ -112,4 +112,11 @@ config OF_OVERLAY
- config OF_NUMA
+@@ -116,4 +116,11 @@ config OF_DMA_DEFAULT_COHERENT
+       # arches should select this if DMA is coherent by default for OF devices
        bool
  
 +config OF_CONFIGFS
        bool
  
 +config OF_CONFIGFS
index 6b2b9f5ae8a569251c83424426439f19aaa4d11a..2bad32a559b5b6f95d455bc54d00015fd95c11a5 100644 (file)
@@ -19,7 +19,7 @@ Subject: [PATCH 210/210] b44: register adm switch
  
  #include <asm/uaccess.h>
  #include <asm/io.h>
  
  #include <asm/uaccess.h>
  #include <asm/io.h>
-@@ -2250,6 +2252,69 @@ static void b44_adjust_link(struct net_d
+@@ -2253,6 +2255,69 @@ static void b44_adjust_link(struct net_d
        }
  }
  
        }
  }
  
@@ -89,7 +89,7 @@ Subject: [PATCH 210/210] b44: register adm switch
  static int b44_register_phy_one(struct b44 *bp)
  {
        struct mii_bus *mii_bus;
  static int b44_register_phy_one(struct b44 *bp)
  {
        struct mii_bus *mii_bus;
-@@ -2285,6 +2350,9 @@ static int b44_register_phy_one(struct b
+@@ -2288,6 +2353,9 @@ static int b44_register_phy_one(struct b
        if (!mdiobus_is_registered_device(bp->mii_bus, bp->phy_addr) &&
            (sprom->boardflags_lo & (B44_BOARDFLAG_ROBO | B44_BOARDFLAG_ADM))) {
  
        if (!mdiobus_is_registered_device(bp->mii_bus, bp->phy_addr) &&
            (sprom->boardflags_lo & (B44_BOARDFLAG_ROBO | B44_BOARDFLAG_ADM))) {
  
@@ -99,7 +99,7 @@ Subject: [PATCH 210/210] b44: register adm switch
                dev_info(sdev->dev,
                         "could not find PHY at %i, use fixed one\n",
                         bp->phy_addr);
                dev_info(sdev->dev,
                         "could not find PHY at %i, use fixed one\n",
                         bp->phy_addr);
-@@ -2476,6 +2544,7 @@ static void b44_remove_one(struct ssb_de
+@@ -2479,6 +2547,7 @@ static void b44_remove_one(struct ssb_de
        unregister_netdev(dev);
        if (bp->flags & B44_FLAG_EXTERNAL_PHY)
                b44_unregister_phy_one(bp);
        unregister_netdev(dev);
        if (bp->flags & B44_FLAG_EXTERNAL_PHY)
                b44_unregister_phy_one(bp);
index a69e9215addffc9650b133d1c19bb4fb93819699..59f76c95535e15975614ad00f9e8b5709bb751b2 100644 (file)
@@ -43,7 +43,7 @@
  
        if (bp->flags & B44_FLAG_EXTERNAL_PHY)
                return 0;
  
        if (bp->flags & B44_FLAG_EXTERNAL_PHY)
                return 0;
-@@ -2180,6 +2205,8 @@ static int b44_get_invariants(struct b44
+@@ -2183,6 +2208,8 @@ static int b44_get_invariants(struct b44
         * valid PHY address. */
        bp->phy_addr &= 0x1F;
  
         * valid PHY address. */
        bp->phy_addr &= 0x1F;
  
index 4958c0b7fdadda8655ac0674898daf07a44b422d..525170a9c8f27054882302bb1445eb9d912e8583 100644 (file)
@@ -87,7 +87,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                        pkt_len = le32_to_cpu(rx_desc->opts1) & RX_LEN_MASK;
                        if (pkt_len < ETH_ZLEN)
                                break;
                        pkt_len = le32_to_cpu(rx_desc->opts1) & RX_LEN_MASK;
                        if (pkt_len < ETH_ZLEN)
                                break;
-@@ -4519,6 +4524,7 @@ static struct usb_device_id rtl8152_tabl
+@@ -4520,6 +4525,7 @@ static struct usb_device_id rtl8152_tabl
        {REALTEK_USB_DEVICE(VENDOR_ID_LENOVO,  0x304f)},
        {REALTEK_USB_DEVICE(VENDOR_ID_LINKSYS, 0x0041)},
        {REALTEK_USB_DEVICE(VENDOR_ID_NVIDIA,  0x09ff)},
        {REALTEK_USB_DEVICE(VENDOR_ID_LENOVO,  0x304f)},
        {REALTEK_USB_DEVICE(VENDOR_ID_LINKSYS, 0x0041)},
        {REALTEK_USB_DEVICE(VENDOR_ID_NVIDIA,  0x09ff)},
@@ -315,8 +315,8 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        /* Adjust Frame Length */
        dwc3_frame_length_adjustment(dwc);
  
        /* Adjust Frame Length */
        dwc3_frame_length_adjustment(dwc);
  
-@@ -938,11 +1052,117 @@ static void dwc3_core_exit_mode(struct d
-       }
+@@ -941,11 +1055,117 @@ static void dwc3_core_exit_mode(struct d
+       dwc3_set_mode(dwc, DWC3_GCTL_PRTCAP_DEVICE);
  }
  
 +static void dwc3_get_properties(struct dwc3 *dwc)
  }
  
 +static void dwc3_get_properties(struct dwc3 *dwc)
@@ -433,7 +433,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        struct resource         *res;
        struct dwc3             *dwc;
        u8                      lpm_nyet_threshold;
        struct resource         *res;
        struct dwc3             *dwc;
        u8                      lpm_nyet_threshold;
-@@ -974,6 +1194,11 @@ static int dwc3_probe(struct platform_de
+@@ -977,6 +1197,11 @@ static int dwc3_probe(struct platform_de
        dwc->xhci_resources[0].flags = res->flags;
        dwc->xhci_resources[0].name = res->name;
  
        dwc->xhci_resources[0].flags = res->flags;
        dwc->xhci_resources[0].name = res->name;
  
@@ -445,7 +445,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        res->start += DWC3_GLOBALS_REGS_START;
  
        /*
        res->start += DWC3_GLOBALS_REGS_START;
  
        /*
-@@ -1016,6 +1241,12 @@ static int dwc3_probe(struct platform_de
+@@ -1019,6 +1244,12 @@ static int dwc3_probe(struct platform_de
        dwc->usb3_lpm_capable = device_property_read_bool(dev,
                                "snps,usb3_lpm_capable");
  
        dwc->usb3_lpm_capable = device_property_read_bool(dev,
                                "snps,usb3_lpm_capable");
  
@@ -458,7 +458,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        dwc->disable_scramble_quirk = device_property_read_bool(dev,
                                "snps,disable_scramble_quirk");
        dwc->u2exit_lfps_quirk = device_property_read_bool(dev,
        dwc->disable_scramble_quirk = device_property_read_bool(dev,
                                "snps,disable_scramble_quirk");
        dwc->u2exit_lfps_quirk = device_property_read_bool(dev,
-@@ -1060,6 +1291,8 @@ static int dwc3_probe(struct platform_de
+@@ -1063,6 +1294,8 @@ static int dwc3_probe(struct platform_de
        dwc->hird_threshold = hird_threshold
                | (dwc->is_utmi_l1_suspend << 4);
  
        dwc->hird_threshold = hird_threshold
                | (dwc->is_utmi_l1_suspend << 4);
  
@@ -467,7 +467,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        platform_set_drvdata(pdev, dwc);
        dwc3_cache_hwparams(dwc);
  
        platform_set_drvdata(pdev, dwc);
        dwc3_cache_hwparams(dwc);
  
-@@ -1083,6 +1316,11 @@ static int dwc3_probe(struct platform_de
+@@ -1086,6 +1319,11 @@ static int dwc3_probe(struct platform_de
        if (ret < 0)
                goto err1;
  
        if (ret < 0)
                goto err1;
  
index 6f7c243ee4b68630a8907c2c130b26219deefc99..fcb348168ff2ab1aee6252a7292e5981dc4f8b50 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/Kconfig
 +++ b/arch/powerpc/Kconfig
 --- a/arch/powerpc/Kconfig
 +++ b/arch/powerpc/Kconfig
-@@ -713,6 +713,14 @@ config CMDLINE_FORCE
+@@ -714,6 +714,14 @@ config CMDLINE_FORCE
          This is useful if you cannot or don't want to change the
          command-line options your boot loader passes to the kernel.
  
          This is useful if you cannot or don't want to change the
          command-line options your boot loader passes to the kernel.