brcm47xx: add mips74k subtarget for newer devices
authorHauke Mehrtens <hauke@hauke-m.de>
Thu, 5 Jun 2014 21:25:03 +0000 (21:25 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 5 Jun 2014 21:25:03 +0000 (21:25 +0000)
All new devices (with MIPS 74K CPU) are based on BCMA SoC and have
Ethernet core supported by bgmac. Create a new subtarget to generate
optimized builds.
This is just a beginning, further tweaks (like kernel configuration)
are still possible. This decreases default root.squashfs by ~128 kB.

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
SVN-Revision: 41025

target/linux/brcm47xx/Makefile
target/linux/brcm47xx/mips74k/profiles/100-Broadcom-b43.mk [new file with mode: 0644]
target/linux/brcm47xx/mips74k/profiles/101-Broadcom-brcsmac.mk [new file with mode: 0644]
target/linux/brcm47xx/mips74k/profiles/102-Broadcom-wl.mk [new file with mode: 0644]
target/linux/brcm47xx/mips74k/profiles/103-Broadcom-none.mk [new file with mode: 0644]
target/linux/brcm47xx/mips74k/target.mk [new file with mode: 0644]

index fa5d21bbe9f3c540a026e6fe0fd11f01a236f6dc..17a9e314bfc6178d4e188fd0375b495e139890da 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mipsel
 BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM47xx/53xx (MIPS)
 FEATURES:=squashfs usb pcmcia low_mem
-SUBTARGETS:=generic
+SUBTARGETS:=generic mips74k
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 
 LINUX_VERSION:=3.10.36
diff --git a/target/linux/brcm47xx/mips74k/profiles/100-Broadcom-b43.mk b/target/linux/brcm47xx/mips74k/profiles/100-Broadcom-b43.mk
new file mode 100644 (file)
index 0000000..7d3c6a7
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-mips74k-b43
+  NAME:=Broadcom SoC, BCM43xx WiFi (b43)
+  PACKAGES:=kmod-bgmac kmod-b43
+endef
+
+define Profile/Broadcom-mips74k-b43/Description
+       Package set for devices with BCM43xx WiFi including mac80211 and b43
+       driver.
+endef
+
+$(eval $(call Profile,Broadcom-mips74k-b43))
+
diff --git a/target/linux/brcm47xx/mips74k/profiles/101-Broadcom-brcsmac.mk b/target/linux/brcm47xx/mips74k/profiles/101-Broadcom-brcsmac.mk
new file mode 100644 (file)
index 0000000..2d09cd2
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-mips74k-brcmsmac
+  NAME:=Broadcom SoC, BCM43xx WiFi (brcmsmac)
+  PACKAGES:=kmod-bgmac kmod-brcmsmac
+endef
+
+define Profile/Broadcom-mips74k-brcmsmac/Description
+       Package set for devices with BCM43xx WiFi including mac80211 and
+       brcmsmac driver.
+endef
+
+$(eval $(call Profile,Broadcom-mips74k-brcmsmac))
+
diff --git a/target/linux/brcm47xx/mips74k/profiles/102-Broadcom-wl.mk b/target/linux/brcm47xx/mips74k/profiles/102-Broadcom-wl.mk
new file mode 100644 (file)
index 0000000..37063ac
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-mips74k-wl
+  NAME:=Broadcom SoC, BCM43xx WiFi (proprietary wl)
+  PACKAGES:=kmod-bgmac -wpad-mini kmod-brcm-wl wlc nas
+endef
+
+define Profile/Broadcom-mips74k-wl/Description
+       Package set for devices with BCM43xx WiFi including proprietary (and
+       closed source) driver "wl".
+endef
+
+$(eval $(call Profile,Broadcom-mips74k-wl))
+
diff --git a/target/linux/brcm47xx/mips74k/profiles/103-Broadcom-none.mk b/target/linux/brcm47xx/mips74k/profiles/103-Broadcom-none.mk
new file mode 100644 (file)
index 0000000..bfe3719
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-mips74k-none
+  NAME:=Broadcom SoC, No WiFi
+  PACKAGES:=kmod-bgmac -wpad-mini
+endef
+
+define Profile/Broadcom-mips74k-none/Description
+       Package set for devices without a WiFi.
+endef
+
+$(eval $(call Profile,Broadcom-mips74k-none))
+
diff --git a/target/linux/brcm47xx/mips74k/target.mk b/target/linux/brcm47xx/mips74k/target.mk
new file mode 100644 (file)
index 0000000..ab7af28
--- /dev/null
@@ -0,0 +1,6 @@
+BOARDNAME:=MIPS 74K
+
+define Target/Description
+       Build firmware for Broadcom BCM47xx and BCM53xx devices with
+       MIPS 74K CPU.
+endef