include UbinizeImage parameters' description in the file
authorImre Kaloz <kaloz@openwrt.org>
Fri, 27 Jun 2014 10:32:09 +0000 (10:32 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 27 Jun 2014 10:32:09 +0000 (10:32 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 41356

include/image.mk

index 3832b7ae8405e3f0d9ea13c242a82bae303e74b4..71971e21ca50910e5688114713a0fc5fe3efe508 100644 (file)
@@ -141,6 +141,11 @@ ifneq ($(CONFIG_NAND_SUPPORT),)
        (cd "$(KDIR_TMP)"; $(TAR) cvf \
                "$(BIN_DIR)/$(IMG_PREFIX)-$(1)-$(2)-sysupgrade.tar" sysupgrade-$(1))
    endef
+# $(1) board name
+# $(2) ubinize-image options (e.g. --no-kernel and/or --uboot-env)
+# $(3) rootfstype (e.g. squashfs or ubifs)
+# $(4) kernel image file
+# $(5) options to pass-through to ubinize (i.e. $($(PROFILE)_UBI_OPTS)))
    define Image/Build/UbinizeImage
        sh $(TOPDIR)/scripts/ubinize-image.sh $(2) \
                "$(KDIR)/root.$(3)" "$(4)" \