openssl: Make DTLS configurable.
authorRosen Penev <rosenp@gmail.com>
Mon, 26 Sep 2016 20:00:04 +0000 (13:00 -0700)
committerJohn Crispin <john@phrozen.org>
Tue, 27 Sep 2016 15:50:22 +0000 (17:50 +0200)
Signed-off by: Rosen Penev <rosenp@gmail.com>

package/libs/openssl/Config.in
package/libs/openssl/Makefile

index 65da36b..dbcd11a 100644 (file)
@@ -20,6 +20,11 @@ config OPENSSL_WITH_DEPRECATED
        default y
        prompt "Include deprecated APIs"
 
+config OPENSSL_WITH_DTLS
+       bool
+       default n
+       prompt "Enable DTLS support"
+
 config OPENSSL_WITH_COMPRESSION
        bool
        default n
index 0df6f3e..a41686f 100644 (file)
@@ -35,6 +35,7 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_OPENSSL_WITH_SSL3 \
        CONFIG_OPENSSL_HARDWARE_SUPPORT \
        CONFIG_OPENSSL_WITH_DEPRECATED \
+       CONFIG_OPENSSL_WITH_DTLS \
        CONFIG_OPENSSL_WITH_COMPRESSION \
        CONFIG_OPENSSL_WITH_NPN \
        CONFIG_OPENSSL_WITH_PSK \
@@ -130,6 +131,10 @@ ifndef CONFIG_OPENSSL_WITH_DEPRECATED
   OPENSSL_OPTIONS += no-deprecated
 endif
 
+ifndef CONFIG_OPENSSL_WITH_DTLS
+  OPENSSL_OPTIONS += no-dtls
+endif
+
 ifdef CONFIG_OPENSSL_WITH_COMPRESSION
   OPENSSL_OPTIONS += zlib-dynamic
 else