ramips: add support for newifi d2
authorJackson Ming Hu <huming2207@gmail.com>
Fri, 15 Dec 2017 03:51:33 +0000 (11:51 +0800)
committerMathias Kresin <dev@kresin.me>
Thu, 21 Dec 2017 00:05:16 +0000 (01:05 +0100)
Previously Newifi D2 could only use PandoraBox M1's firmware.
It works fine, but LED GPIO is different.
As a result, a separated DTS file for this device should be implemented.

Hardware spec:

* CPU: MTK MT7621A
* RAM: 512MB
* ROM: 32MB SPI Flash
* WiFi: MTK MT7603+MT7612
* Button: 2 buttons (reset, wps)
* LED: 3 single-color LEDs (USB, WiFi 2.4GHz, WiFi 5GHz) &
       2 dual-color LEDs (Power, Internet)
* Ethernet: 5 ports, 4 LAN + 1 WAN

Installation method:

Same as Newifi D1, users may need to request unlock code from the device
manufacturer. Otherwise, a SPI flash programmer may be necessary to get
the firmware flashed. After the device is unlocked, press and hold reset
button before power cable plugs in. Then go to http://192.168.1.1 to
upload and flash the firmware package.

Signed-off-by: Jackson Ming Hu <huming2207@gmail.com>
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/Newifi-D2.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk

index 671a578f80c559cbf6ad69895d8771491731fb62..a5c51c7c8814eb835edab7d31fb5fe69c16b2d69 100755 (executable)
@@ -305,6 +305,12 @@ pbr-m1)
        ucidef_set_led_default "power" "power" "$boardname:blue:power" "1"
        ucidef_set_led_default "sys" "sys" "$boardname:blue:sys" "1"
        ;;
+d-team,newifi-d2)
+       set_usb_led "$boardname:blue:usb"
+       ucidef_set_led_switch "internet" "internet" "$boardname:amber:internet" "switch0" "0x10"
+       ucidef_set_led_netdev "wlan2g" "WiFi 2.4GHz" "$boardname:blue:wlan2g" "wlan0"
+       ucidef_set_led_netdev "wlan5g" "WiFi 5GHz" "$boardname:blue:wlan5g" "wlan1"
+       ;;
 psg1208)
        set_wifi_led "$boardname:white:wlan2g"
        ;;
index 947b0dd8aea6a49d164196f6451547ef7f6b2970..5a64bb727a62158b623e68da407bc586517d75cd 100755 (executable)
@@ -92,6 +92,7 @@ ramips_setup_interfaces()
        mt7628|\
        mzk-750dhp|\
        mzk-w300nh2|\
+       d-team,newifi-d2|\
        nixcore-x1-8M|\
        nixcore-x1-16M|\
        oy-0001|\
index 1d4b0eff3f38e7e1dc491147748430abf92232d9..e7b49a5039d637c4f2be64c58c2b27edcd354bb0 100644 (file)
@@ -125,6 +125,7 @@ get_status_led() {
        d240|\
        dap-1350|\
        na930|\
+       d-team,newifi-d2|\
        pbr-m1|\
        re350-v1|\
        rt-ac51u|\
index d95dcfe17a6cc01cb15cc461e266bbe88ae2f21c..68b47eeba03a1b40b9661151cb632fccbfe5cae9 100755 (executable)
@@ -107,6 +107,7 @@ platform_check_image() {
        nbg-419n|\
        nbg-419n2|\
        newifi-d1|\
+       d-team,newifi-d2|\
        nixcore-x1-8M|\
        nixcore-x1-16M|\
        nw718|\
diff --git a/target/linux/ramips/dts/Newifi-D2.dts b/target/linux/ramips/dts/Newifi-D2.dts
new file mode 100644 (file)
index 0000000..e919338
--- /dev/null
@@ -0,0 +1,159 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "d-team,newifi-d2", "mediatek,mt7621-soc";
+       model = "Newifi-D2";
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x1c000000>, <0x20000000 0x4000000>;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               power-amber {
+                       label = "newifi-d2:amber:power";
+                       gpios = <&gpio0 6 GPIO_ACTIVE_LOW>;
+               };
+
+               power-blue {
+                       label = "newifi-d2:blue:power";
+                       gpios = <&gpio0 15 GPIO_ACTIVE_LOW>;
+               };
+
+               internet-amber {
+                       label = "newifi-d2:amber:internet";
+                       gpios = <&gpio0 4 GPIO_ACTIVE_LOW>;
+               };
+
+               internet-blue {
+                       label = "newifi-d2:blue:internet";
+                       gpios = <&gpio0 13 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan2g {
+                       label = "newifi-d2:blue:wlan2g";
+                       gpios = <&gpio0 14 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan5g {
+                       label = "newifi-d2:blue:wlan5g";
+                       gpios = <&gpio0 16 GPIO_ACTIVE_LOW>;
+               };
+
+               usb {
+                       label = "newifi-d2:blue:usb";
+                       gpios = <&gpio0 10 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 3 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 7 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+       };
+
+       gpio_export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+
+               power_usb3 {
+                       gpio-export,name = "power_usb3";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio0 11 GPIO_ACTIVE_HIGH>;
+               };
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       m25p80@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+               m25p,chunked-io = <32>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+
+               factory: partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+
+               partition@50000 {
+                       label = "firmware";
+                       reg = <0x50000 0x1fb0000>;
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+
+       pcie0 {
+               mt76@0,0 {
+                       reg = <0x0000 0 0 0 0>;
+                       device_type = "pci";
+                       mediatek,mtd-eeprom = <&factory 0x8000>;
+                       ieee80211-freq-limit = <5000000 6000000>;
+               };
+       };
+
+       pcie1 {
+               mt76@1,0 {
+                       reg = <0x0000 0 0 0 0>;
+                       device_type = "pci";
+                       mediatek,mtd-eeprom = <&factory 0x0000>;
+               };
+       };
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0xe000>;
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "i2c", "jtag", "uart2", "uart3";
+                       ralink,function = "gpio";
+               };
+       };
+};
index ca1e3661b1d4e6ecbba4da7d5e1fe7176c1889b8..8ba65a1af2ca36b95cae03e4f8fb9a920d667e71 100644 (file)
@@ -142,6 +142,15 @@ define Device/newifi-d1
 endef
 TARGET_DEVICES += newifi-d1
 
+define Device/d-team_newifi-d2
+  DTS := Newifi-D2
+  IMAGE_SIZE := $(ralink_default_fw_size_32M)
+  DEVICE_TITLE := Newifi D2
+  DEVICE_PACKAGES := \
+       kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += d-team_newifi-d2
+
 define Device/pbr-m1
   DTS := PBR-M1
   IMAGE_SIZE := $(ralink_default_fw_size_16M)