add a prereq check for umask 0022, other settings will result in broken packages
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 14 Oct 2010 14:25:29 +0000 (14:25 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 14 Oct 2010 14:25:29 +0000 (14:25 +0000)
SVN-Revision: 23442

include/prereq-build.mk

index 84d3f22..afb92ff 100644 (file)
@@ -18,6 +18,13 @@ $(eval $(call Require,non-root, \
        Please do not compile as root. \
 ))
 
+define Require/umask-0022
+       [ "$$(shell umask)" -eq 22 ]
+endef
+$(eval $(call Require,umask-0022, \
+       Please compile with umask 0022. \
+))
+
 # Required for the toolchain
 define Require/working-make
        $(MAKE) -v | awk '($$$$1 == "GNU") && ($$$$2 = "Make") && ($$$$3 >= "3.81") { print "ok" }' | grep ok > /dev/null