ramips: drop pointless default led definitions
authorMathias Kresin <dev@kresin.me>
Sat, 18 Aug 2018 10:07:08 +0000 (12:07 +0200)
committerMathias Kresin <dev@kresin.me>
Wed, 29 Aug 2018 07:39:32 +0000 (09:39 +0200)
The LEDs should be triggered/lit by any kind of state change instead of
turned on/off unconditional.

If LEDs really need to be turned off by default, it should be done via
the default-state devicetree led property.

The handling of the wndr3700v5 and wt3020 power led is at least
strange. Something is for sure wrong with them. Either the leds are
misnamed, the default off trigger is a typo or the polarity of the
gpios is wrong. Drop the power led from userspace and wait for someone
with access to the hardware to fix it properly.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/base-files/etc/board.d/01_leds

index c92712c..8bf7ef3 100755 (executable)
@@ -123,7 +123,6 @@ dcs-930l-b1)
 dir-300-b1|\
 dir-600-b1|\
 dir-620-a1)
-       ucidef_set_led_default "wan" "WAN LED (amber)" "$boardname:amber:wan" "1"
        set_wifi_led "rt2800pci-phy0::radio"
        ;;
 dir-300-b7|\
@@ -213,7 +212,6 @@ hc5861)
        ucidef_set_led_netdev "internet" "internet" "$boardname:blue:internet" "eth0.2"
        set_wifi_led "$boardname:blue:wlan2g"
        ucidef_set_led_netdev "wifi5g" "wifi5g" "$boardname:blue:wlan5g" "rai0"
-       ucidef_set_led_default "turbo" "turbo" "$boardname:blue:turbo" "0"
        ;;
 hg255d)
        set_wifi_led "$boardname:green:wlan"
@@ -335,9 +333,6 @@ re350-v1)
        ucidef_set_led_netdev "eth_act" "LAN act" "$boardname:green:eth_act" "eth0" "tx rx"
        ucidef_set_led_switch "eth_link" "LAN link" "$boardname:green:eth_link" "switch0" "0x01"
        ;;
-re6500)
-       ucidef_set_led_default "wifi" "wifi" "$boardname:orange:wifi" "1"
-       ;;
 rp-n53)
        ucidef_set_led_netdev "eth" "Network" "$boardname:white:back" "eth0"
        set_wifi_led "$boardname:blue:wifi"
@@ -457,11 +452,6 @@ we1026-5g-16m)
        set_wifi_led "we1026-5g:green:wifi"
        set_usb_led "we1026-5g:green:usb" "1-1.1"
        ;;
-whr-1166d|\
-whr-300hp2|\
-whr-600d)
-       ucidef_set_led_default "router" "router" "$boardname:green:router" "1"
-       ;;
 wl-wn575a3)
        ucidef_set_rssimon "wlan1" "200000" "1"
        ucidef_set_led_rssi "wifi-low" "wifi-low" "$boardname:green:wifi-low" "wlan1" "1" "49"
@@ -472,13 +462,6 @@ wrh-300cr)
        set_wifi_led "$boardname:green:wlan"
        ucidef_set_led_netdev "lan" "lan" "$boardname:green:ethernet" "eth0"
        ;;
-wndr3700v5)
-       ucidef_set_led_default "power" "POWER" "$boardname:green:power" "0"
-       ;;
-wt3020-4M|\
-wt3020-8M)
-       ucidef_set_led_default "power" "power" "wt3020:blue:power" "0"
-       ;;
 y1)
        set_usb_led "$boardname:blue:usb"
        ucidef_set_led_netdev "wifi" "WIFI" "$boardname:blue:wifi" "wlan1"