Add support for the WL-500gP v2
authorAndy Boyett <agb@openwrt.org>
Mon, 31 Mar 2008 08:04:56 +0000 (08:04 +0000)
committerAndy Boyett <agb@openwrt.org>
Mon, 31 Mar 2008 08:04:56 +0000 (08:04 +0000)
SVN-Revision: 10693

package/broadcom-diag/Makefile
package/broadcom-diag/src/diag.c
target/linux/brcm-2.4/base-files/etc/init.d/netconfig

index 0158779c680e8d21083870993918cada81d27d6d..19fd4cb87f591e77bbcfa6751a1351e9f653ea3a 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=broadcom-diag
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 include $(INCLUDE_DIR)/package.mk
 
index 3f92997375ca40cc4871088c64954011d43d4c81..b670944e02d3c5c1a8f6aa67c1611f95c7268013 100644 (file)
@@ -284,6 +284,17 @@ static struct platform_t __initdata platforms[] = {
                        { .name = "power",      .gpio = 1 << 1, .polarity = REVERSE },
                },
        },
+       [WL500GPV2] = {
+               .name           = "ASUS WL-500g Premium V2",
+               .buttons        = {
+                       { .name = "reset",      .gpio = 1 << 2 },
+                       { .name = "ses",        .gpio = 1 << 3 },
+               },
+               .leds           = {
+                       { .name = "power",      .gpio = 1 << 0, .polarity = REVERSE },
+                       { .name = "wlan",       .gpio = 1 << 1, .polarity = REVERSE },
+               },
+       },
        [WL500W] = {
                .name           = "ASUS WL-500W",
                .buttons        = {
@@ -674,6 +685,8 @@ static struct platform_t __init *platform_detect(void)
 
        /* Based on "hardware_version" */
        if (buf = nvram_get("hardware_version")) {
+               if (startswith(buf,"WL500GPV2-")) /* WL500GPV2-* */
+                       return &platforms[WL500GPV2];
                if (startswith(buf,"WL520GU-")) /* WL520GU-* */
                        return &platforms[WL520GU];
        }
index b207bd45a89dd65a7fccc0a60725e3ebf0953b64..c8743539d82f5839be180df9d4a1709ad41f0053 100755 (executable)
@@ -61,6 +61,11 @@ start() {
                        c["wan_ifname"] = "eth1"
                        c["lan_ifname"] = "eth0"
                }
+               if (model == "ASUS WL-500g Premium V2") {
+                               c["vlan0ports"] = "0 1 2 3 5*"
+                               c["vlan1ports"] = "4 5"
+               }
+
                if (model == "Dell TrueMobile 2300") {
                        c["vlan0ports"] = "0 1 2 3 5*"
                        c["vlan1ports"] = "4 5"