increase kernel partition size to fix boot issues
authorImre Kaloz <kaloz@openwrt.org>
Fri, 21 Jun 2013 10:57:05 +0000 (10:57 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 21 Jun 2013 10:57:05 +0000 (10:57 +0000)
SVN-Revision: 36982

target/linux/ppc40x/image/Makefile
target/linux/ppc40x/patches-3.8/004-magicbox.patch
target/linux/ppc40x/patches-3.8/005-openrb.patch

index 415539e9cc0ad00b4d892ed9d3371594dfde5918..dae5de5dff4f7a2b263ebac28e40419ce0f3d72d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -37,11 +37,11 @@ endef
 
 define Image/Build/jffs2-64k
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox bs=1280k conv=sync; \
+               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox bs=1408k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
        ) > $(BIN_DIR)/$(IMG_PREFIX)-magicbox-jffs2.img
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb bs=1280k conv=sync; \
+               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb bs=1408k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
        ) > $(BIN_DIR)/$(IMG_PREFIX)-openrb-jffs2.img
 endef
@@ -54,11 +54,11 @@ define Image/Build/squashfs
                dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
        ) > $(BIN_DIR)/$(IMG_PREFIX)-kilauea-$(1).img
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox bs=1280k conv=sync; \
+               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox bs=1408k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
        ) > $(BIN_DIR)/$(IMG_PREFIX)-magicbox-$(1).img
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb bs=1280k conv=sync; \
+               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb bs=1408k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
        ) > $(BIN_DIR)/$(IMG_PREFIX)-openrb-$(1).img
 endef
index 75ff8897988b4a727643a52a9414ec97cbed1a7a..717b1f7760cb6bee3c590bacce2870b8dd0b1fc9 100644 (file)
 +                              #size-cells = <1>;
 +                              partition0@0 {
 +                                      label = "linux";
-+                                      reg = <0x0 0x140000>;
++                                      reg = <0x0 0x160000>;
 +                              };
 +                              partition1@120000 {
 +                                      label = "rootfs";
-+                                      reg = <0x140000 0x280000>;
++                                      reg = <0x160000 0x260000>;
 +                              };
 +                              partition2@3c0000 {
 +                                      label = "u-boot";
index 3c1f0ae503c097e08ec235f5efd0dfe7248ae7da..116ee09ca3211546c5fbed1dd870c66d8d620f4c 100644 (file)
 +                              #size-cells = <1>;
 +                              partition0@0 {
 +                                      label = "linux";
-+                                      reg = <0x0 0x140000>;
++                                      reg = <0x0 0x160000>;
 +                              };
 +                              partition1@120000 {
 +                                      label = "rootfs";
-+                                      reg = <0x140000 0x680000>;
++                                      reg = <0x160000 0x660000>;
 +                              };
 +                              partition2@7c0000 {
 +                                      label = "u-boot";