This patch adds a kmod in hwmon for the SHT21 sensor (I2C temperature and humidity...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 18 Mar 2012 19:49:17 +0000 (19:49 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 18 Mar 2012 19:49:17 +0000 (19:49 +0000)
Signed-off-by: Christian Gagneraud <chris@techworks.ie>
SVN-Revision: 30986

package/kernel/modules/hwmon.mk

index 57dd5684cbc44d30247bbee42641a92ef0ef2f2a..61b5b3d602f75e616ed5eca04f471c834b4c6a5c 100644 (file)
@@ -103,6 +103,19 @@ endef
 
 $(eval $(call KernelPackage,hwmon-lm95241))
 
+define KernelPackage/hwmon-sht21
+  TITLE:=Sensiron SHT21 and compat. monitoring support
+  KCONFIG:=CONFIG_SENSORS_SHT21
+  FILES:=$(LINUX_DIR)/drivers/hwmon/sht21.ko
+  AUTOLOAD:=$(call AutoLoad,60,sht21)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-sht21/description
+ Kernel module for Sensirion SHT21 and SHT25 temperature and humidity sensors chip
+endef
+
+$(eval $(call KernelPackage,hwmon-sht21))
 
 define KernelPackage/hwmon-pc87360
   TITLE:=PC87360 monitoring support