ar71xx: add support for TP-LINK TL-WR841N/ND v10
authorJohn Crispin <john@openwrt.org>
Mon, 26 Oct 2015 09:01:41 +0000 (09:01 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 26 Oct 2015 09:01:41 +0000 (09:01 +0000)
The TL-WR841N/ND v10 is mostly identical to the v9. Apart from some minor
changes, it contains a newer revision of the QCA9533 SoC and the CPU clock
is significantly higher.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
SVN-Revision: 47263

target/linux/ar71xx/image/Makefile

index 7759a0d68129f45e64c494c70b0a6b16db05c7cb..a659af9fa6980fa7bc507a7674461dd228cabe6c 100644 (file)
@@ -704,6 +704,13 @@ define Device/tl-wr841n-v9
     TPLINK_HWID := 0x08410009
 endef
 
     TPLINK_HWID := 0x08410009
 endef
 
+define Device/tl-wr841n-v10
+    $(Device/tplink-4mlzma)
+    BOARDNAME := TL-WR841N-v9
+    DEVICE_PROFILE := TLWR841
+    TPLINK_HWID := 0x08410010
+endef
+
 define Device/tl-wr842n-v1
     $(Device/tplink-8m)
     BOARDNAME := TL-MR3420
 define Device/tl-wr842n-v1
     $(Device/tplink-8m)
     BOARDNAME := TL-MR3420
@@ -731,7 +738,7 @@ define Device/tl-wr847n-v8
     DEVICE_PROFILE := TLWR841
     TPLINK_HWID := 0x08470008
 endef
     DEVICE_PROFILE := TLWR841
     TPLINK_HWID := 0x08470008
 endef
-TARGET_DEVICES += tl-wr841nd-v3 tl-wr841nd-v5 tl-wr841nd-v7 tl-wr841n-v8 tl-wr841n-v9 tl-wr842n-v1 tl-wr842n-v2 tl-wr843nd-v1 tl-wr847n-v8
+TARGET_DEVICES += tl-wr841nd-v3 tl-wr841nd-v5 tl-wr841nd-v7 tl-wr841n-v8 tl-wr841n-v9 tl-wr841n-v10 tl-wr842n-v1 tl-wr842n-v2 tl-wr843nd-v1 tl-wr847n-v8
 
 define Device/tl-wr941nd-v2
     $(Device/tplink-4m)
 
 define Device/tl-wr941nd-v2
     $(Device/tplink-4m)