ath79: lzma-loader: sync with ar71xx target
authorMatthias Schiffer <mschiffer@universe-factory.net>
Wed, 6 Jun 2018 19:01:32 +0000 (21:01 +0200)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Wed, 6 Jun 2018 20:25:53 +0000 (22:25 +0200)
Import all improvements made in the lzma-loader since development on the
ath79 target started.

This also reverts fe594bf90d09 ("ath79: fix loader-okli, lzma-loader"), as
is obsoleted by 2ad60168b6af ("ar71xx: lzma-loader: move padding workaround
to gzip step").

Likely, many of the changes should be ported to the ramips lzma-loader as
well, but I don't have a device to test this.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
target/linux/ath79/image/Makefile
target/linux/ath79/image/common-tp-link.mk
target/linux/ath79/image/lzma-loader/Makefile
target/linux/ath79/image/lzma-loader/src/Makefile
target/linux/ath79/image/lzma-loader/src/head.S
target/linux/ath79/image/lzma-loader/src/loader.c
target/linux/ath79/image/lzma-loader/src/loader.lds

index cd136b23b9ba0365dcf6a0185bdb2997ccad77a5..34dd81961032203dfd4bbca5ba14a3082b80fece 100644 (file)
@@ -29,8 +29,9 @@ define Build/loader-okli-compile
        $(call Build/loader-common,FLASH_OFFS=$(LOADER_FLASH_OFFS) FLASH_MAX=0)
 endef
 
+# Arguments: <output name> <kernel offset>
 define Build/loader-okli
-       dd if=$(KDIR)/loader-$(1).gz bs=7680 conv=sync of="$@.new"
+       dd if=$(KDIR)/loader-$(word 1,$(1)).$(LOADER_TYPE) bs=$(word 2,$(1)) conv=sync of="$@.new"
        cat "$@" >> "$@.new"
        mv "$@.new" "$@"
 endef
index 1dd5a289f253ffe6e484b5bd3cbc3969570421a5..dcd651722da1f851115784018bf1b5676bc3b5df 100644 (file)
@@ -55,7 +55,7 @@ define Device/tplink-nolzma
   LOADER_FLASH_OFFS := 0x22000
   COMPILE := loader-$(1).gz
   COMPILE/loader-$(1).gz := loader-okli-compile
-  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49 | loader-okli $(1)
+  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49 | loader-okli $(1) 7680
   KERNEL_INITRAMFS := kernel-bin | append-dtb | gzip | tplink-v1-header
 endef
 
index 9b81e87306f235d1e7284401828240b9b9787011..738093a958013624abb8f84a3874e1c795da349d 100644 (file)
@@ -47,7 +47,11 @@ loader-compile: $(PKG_BUILD_DIR)/.prepared
                clean all
 
 loader.gz: $(PKG_BUILD_DIR)/loader.bin
-       gzip -nc9 $< > $(LOADER_GZ)
+       # Workaround for buggy bootloaders: Some devices
+       # (TP-Link TL-WR1043ND v1) don't work correctly when
+       # the uncompressed loader is too small (probably a cache
+       # invalidation issue)
+       dd if=$< bs=512K conv=sync | gzip -nc9 > $(LOADER_GZ)
 
 loader.elf: $(PKG_BUILD_DIR)/loader.elf
        $(CP) $< $(LOADER_ELF)
index 133bf6ee8f57a17d3635d900b49dac53d7dea42e..7773f027a24975bb7204b1dec141e3bd39092874 100644 (file)
@@ -21,7 +21,6 @@ LOADER_DATA   :=
 BOARD          :=
 FLASH_OFFS     :=
 FLASH_MAX      :=
-KERNEL_CMDLINE := rootfstype=squashfs
 
 CC             := $(CROSS_COMPILE)gcc
 LD             := $(CROSS_COMPILE)ld
@@ -34,15 +33,17 @@ BIN_FLAGS   := -O binary -R .reginfo -R .note -R .comment -R .mdebug \
 CFLAGS         = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
                  -fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 \
                  -mno-abicalls -fno-pic -ffunction-sections -pipe -mlong-calls \
-                 -fno-common -ffreestanding -fhonour-copts \
+                 -fno-common -ffreestanding -fhonour-copts -nostartfiles \
                  -mabi=32 -march=mips32r2 \
                  -Wa,-32 -Wa,-march=mips32r2 -Wa,-mips32r2 -Wa,--trap
 CFLAGS         += -D_LZMA_PROB32
+CFLAGS         += -flto
 
 ASFLAGS                = $(CFLAGS) -D__ASSEMBLY__
 
-LDFLAGS                = -static --gc-sections -no-warn-mismatch
-LDFLAGS                += -e startup -T loader.lds -Ttext $(LZMA_TEXT_START)
+LDFLAGS                = -static -Wl,--gc-sections -Wl,-no-warn-mismatch
+LDFLAGS                += -Wl,-e,startup -T loader.lds -Wl,-Ttext,$(LZMA_TEXT_START)
+LDFLAGS                += -flto -fwhole-program
 
 O_FORMAT       = $(shell $(OBJDUMP) -i | head -2 | grep elf32)
 
@@ -87,7 +88,7 @@ data.o: $(LOADER_DATA)
        $(LD) -r -b binary --oformat $(O_FORMAT) -T lzma-data.lds -o $@ $<
 
 loader: $(OBJECTS)
-       $(LD) $(LDFLAGS) -o $@ $(OBJECTS)
+       $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(OBJECTS)
 
 loader.bin: loader
        $(OBJCOPY) $(BIN_FLAGS) $< $@
@@ -96,7 +97,7 @@ loader2.o: loader.bin
        $(LD) -r -b binary --oformat $(O_FORMAT) -o $@ $<
 
 loader.elf: loader2.o
-       $(LD) -e startup -T loader2.lds -Ttext $(LOADADDR) -o $@ $<
+       $(LD) -z max-page-size=0x1000 -e startup -T loader2.lds -Ttext $(LOADADDR) -o $@ $<
 
 mrproper: clean
 
index 47a7c9bd6300ad92e6a0d426c5f44bc0f3e7e85f..d414b14d11b9e6cf0655f8d7bda54739a8d6567e 100644 (file)
@@ -42,6 +42,19 @@ LEAF(startup)
        mtc0    t0, CP0_STATUS
        ehb
 
+       /*
+        * Some bootloaders set the 'Kseg0 coherency algorithm' to
+        * 'Cacheable, noncoherent, write-through, no write allocate'
+        * and this cause performance issues. Let's go and change it to
+        * 'Cacheable, noncoherent, write-back, write allocate'
+        */
+       mfc0    t0, CP0_CONFIG
+       li      t1, ~7                  #~CONF_CM_CMASK
+       and     t0, t1
+       ori     t0, 3                   #CONF_CM_CACHABLE_NONCOHERENT
+       mtc0    t0, CP0_CONFIG
+       nop
+
        mtc0    zero, CP0_COUNT
        mtc0    zero, CP0_COMPARE
        ehb
index cc73eb1721cbfbf2ad1bb94e8e6d3ab006983c5d..794c4b6285a7fa0423c22d172828415e6f2be93b 100644 (file)
@@ -75,7 +75,7 @@ static unsigned long kernel_la;
 #ifdef CONFIG_KERNEL_CMDLINE
 #define kernel_argc    2
 static const char kernel_cmdline[] = CONFIG_KERNEL_CMDLINE;
-static const char *kernel_argv[] = {
+static const char *const kernel_argv[] = {
        NULL,
        kernel_cmdline,
        NULL,
index 80cc7ca3ecf53a747fc139560b89c233f4343293..01ff85236147dc62bae480b191a44005171b1561 100644 (file)
@@ -13,7 +13,6 @@ SECTIONS {
        .data : {
                *(.data)
                *(.data.*)
-               . = . + 524288;         /* workaround for buggy bootloaders */
        }
 
        . = ALIGN(32);