ramips: split Phicomm PSG1218 and PSG1218K2C
authorDaniel Golle <daniel@makrotopia.org>
Thu, 20 Apr 2017 22:53:03 +0000 (00:53 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Fri, 21 Apr 2017 00:29:21 +0000 (02:29 +0200)
PSG1218 got only 4 Ethernet ports and WAN on port 3 while
PSG1218K2C got 5 Ethernet ports and WAN on port 4
Switch to use kmod-kt76x2 instead of kmod-mt76 for both devices while
at it.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/PSG1218.dts
target/linux/ramips/dts/PSG1218.dtsi [new file with mode: 0644]
target/linux/ramips/dts/PSG1218K2C.dts [new file with mode: 0644]
target/linux/ramips/image/mt7620.mk

index 4073d803f2f428bd5f4aadf792d575374cdacae8..2c44a83f28e479c7f864f462e77dc2202565db42 100755 (executable)
@@ -287,7 +287,8 @@ pbr-m1)
 psg1208)
        set_wifi_led "$board:white:wlan2g"
        ;;
 psg1208)
        set_wifi_led "$board:white:wlan2g"
        ;;
-psg1218)
+psg1218\|
+psg1218k2c)
        ucidef_set_led_netdev "Network" "Network" "$board:blue:status" "eth0"
        ucidef_set_led_default "status" "STATUS" "$board:yellow:status" "0"
        ;;
        ucidef_set_led_netdev "Network" "Network" "$board:blue:status" "eth0"
        ucidef_set_led_default "status" "STATUS" "$board:yellow:status" "0"
        ;;
index 7bdebbe97f51e94560e8077caa3a81dcf200811e..b2966c26dacbcc0419b6bc049ab688b7031b0d0c 100755 (executable)
@@ -95,7 +95,7 @@ ramips_setup_interfaces()
        oy-0001|\
        pbr-m1|\
        psg1208|\
        oy-0001|\
        pbr-m1|\
        psg1208|\
-       psg1218|\
+       psg1218k2c|\
        r6220|\
        sap-g3200u3|\
        sk-wb8|\
        r6220|\
        sap-g3200u3|\
        sk-wb8|\
@@ -115,6 +115,10 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0:lan" "1:lan" "2:lan" "3:lan" "4:wan" "6@eth0"
                ;;
                ucidef_add_switch "switch0" \
                        "0:lan" "1:lan" "2:lan" "3:lan" "4:wan" "6@eth0"
                ;;
+       psg1218)
+               ucidef_add_switch "switch0" \
+                       "0:lan:3" "1:lan:2" "2:lan:1" "3:wan" "6@eth0"
+               ;;
        whr-300hp2|\
        whr-600d|\
        wsr-1166|\
        whr-300hp2|\
        whr-600d|\
        wsr-1166|\
index 3dbf87ac5d4af12045db2c5aee3890a9e52b0d61..af18264f99c765ebf418a82bd97022729c635d5f 100644 (file)
@@ -104,7 +104,8 @@ get_status_led() {
        psg1208)
                status_led="$board:white:wps"
                ;;
        psg1208)
                status_led="$board:white:wps"
                ;;
-       psg1218)
+       psg1218|\
+       psg1218k2c)
                status_led="$board:yellow:status"
                ;;
        cy-swr1100|\
                status_led="$board:yellow:status"
                ;;
        cy-swr1100|\
index 786aecb99b62d26fe978521e46fda8ec89264b42..a75f5208a3e344dff0eeae3f0e6091f823ef54ac 100755 (executable)
@@ -400,6 +400,9 @@ ramips_board_detect() {
        *"PSG1218")
                name="psg1218"
                ;;
        *"PSG1218")
                name="psg1218"
                ;;
+       *"PSG1218K2C")
+               name="psg1218k2c"
+               ;;
        *"PSR-680W"*)
                name="psr-680w"
                ;;
        *"PSR-680W"*)
                name="psr-680w"
                ;;
index 08fa45ad98b5b4c588ca2bfc76bed849f424682b..827109b59efa2906ed041859d6fd77e5d288771a 100755 (executable)
@@ -113,6 +113,7 @@ platform_check_image() {
        pbr-m1|\
        psg1208|\
        psg1218|\
        pbr-m1|\
        psg1208|\
        psg1218|\
+       psg1218k2c|\
        psr-680w|\
        px-4885|\
        rb750gr3|\
        psr-680w|\
        px-4885|\
        rb750gr3|\
index 1e53dcef3d07c50983dc0ac1278424788af2b008..0492d65502c95d5f1b62f661f33a550d50443391 100644 (file)
@@ -1,8 +1,6 @@
 /dts-v1/;
 
 /dts-v1/;
 
-#include "mt7620a.dtsi"
-
-#include <dt-bindings/input/input.h>
+#include "PSG1218.dtsi"
 
 / {
        compatible = "PSG1218", "ralink,mt7620a-soc";
 
 / {
        compatible = "PSG1218", "ralink,mt7620a-soc";
@@ -10,7 +8,6 @@
 
        gpio-leds {
                compatible = "gpio-leds";
 
        gpio-leds {
                compatible = "gpio-leds";
-
                blue {
                        label = "psg1218:blue:status";
                        gpios = <&gpio0 10 1>;
                blue {
                        label = "psg1218:blue:status";
                        gpios = <&gpio0 10 1>;
 
                red {
                        label = "psg1218:red:status";
 
                red {
                        label = "psg1218:red:status";
-                       gpios = <&gpio0 8 0>;
-               };
-       };
-
-       gpio-keys-polled {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <20>;
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio0 1 1>;
-                       linux,code = <KEY_RESTART>;
-               };
-       };
-};
-
-&gpio0 {
-       status = "okay";
-};
-
-&spi0 {
-       status = "okay";
-
-       m25p80@0 {
-               #address-cells = <1>;
-               #size-cells = <1>;
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <10000000>;
-
-               partition@0 {
-                       label = "u-boot";
-                       reg = <0x0 0x30000>;
-                       read-only;
-               };
-
-               partition@20000 {
-                       label = "u-boot-env";
-                       reg = <0x30000 0x10000>;
-                       read-only;
-               };
-
-               factory: partition@30000 {
-                       label = "factory";
-                       reg = <0x40000 0x10000>;
-                       read-only;
-               };
-
-               partition@40000 {
-                       label = "firmware";
-                       reg = <0x50000 0x7b0000>;
+                               gpios = <&gpio0 8 0>;
                };
        };
 };
                };
        };
 };
 &pinctrl {
        state_default: pinctrl0 {
                gpio {
 &pinctrl {
        state_default: pinctrl0 {
                gpio {
-                       ralink,group = "i2c", "uartf", "rgmii1", "rgmii2", "ephy", "wled", "nd_sd";
+                       ralink,group = "i2c", "uartf", "rgmii1", "rgmii2", "wled", "nd_sd", "pa";
                        ralink,function = "gpio";
                };
                        ralink,function = "gpio";
                };
-
-               pa {
-                       ralink,group = "pa";
-                       ralink,function = "pa";
-               };
        };
 };
 
        };
 };
 
        mtd-mac-address = <&factory 0x28>;
        mediatek,portmap = "llllw";
 };
        mtd-mac-address = <&factory 0x28>;
        mediatek,portmap = "llllw";
 };
-
-&pcie {
-       status = "okay";
-
-       pcie-bridge {
-               mt76@0,0 {
-                       reg = <0x0000 0 0 0 0>;
-                       device_type = "pci";
-                       mediatek,mtd-eeprom = <&factory 0x8000>;
-                       ieee80211-freq-limit = <5000000 6000000>;
-               };
-       };
-};
-
-&wmac {
-       ralink,mtd-eeprom = <&factory 0>;
-};
diff --git a/target/linux/ramips/dts/PSG1218.dtsi b/target/linux/ramips/dts/PSG1218.dtsi
new file mode 100644 (file)
index 0000000..b3b5894
--- /dev/null
@@ -0,0 +1,74 @@
+#include "mt7620a.dtsi"
+
+#include <dt-bindings/input/input.h>
+
+/ {
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 1 1>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+};
+
+&gpio0 {
+       status = "okay";
+};
+
+&spi0 {
+       status = "okay";
+
+       m25p80@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@20000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+
+               factory: partition@30000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+
+               partition@40000 {
+                       label = "firmware";
+                       reg = <0x50000 0x7b0000>;
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+
+       pcie-bridge {
+               mt76@0,0 {
+                       reg = <0x0000 0 0 0 0>;
+                       device_type = "pci";
+                       mediatek,mtd-eeprom = <&factory 0x8000>;
+                       ieee80211-freq-limit = <5000000 6000000>;
+               };
+       };
+};
+
+&wmac {
+       ralink,mtd-eeprom = <&factory 0>;
+};
diff --git a/target/linux/ramips/dts/PSG1218K2C.dts b/target/linux/ramips/dts/PSG1218K2C.dts
new file mode 100644 (file)
index 0000000..d8105b9
--- /dev/null
@@ -0,0 +1,47 @@
+/dts-v1/;
+
+#include "PSG1218.dtsi"
+
+/ {
+       compatible = "PSG1218K2C", "ralink,mt7620a-soc";
+       model = "Phicomm PSG1218K2C";
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               blue {
+                       label = "psg1218k2c:blue:status";
+                       gpios = <&gpio0 10 1>;
+               };
+
+               yellow {
+                       label = "psg1218k2c:yellow:status";
+                       gpios = <&gpio0 11 1>;
+               };
+
+               red {
+                       label = "psg1218k2c:red:status";
+                               gpios = <&gpio0 8 0>;
+               };
+       };
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "i2c", "uartf", "rgmii1", "rgmii2", "wled", "nd_sd";
+                       ralink,function = "gpio";
+               };
+
+               pa {
+                       ralink,group = "pa";
+                       ralink,function = "pa";
+               };
+       };
+};
+
+&ethernet {
+       pinctrl-names = "default";
+       pinctrl-0 = <&ephy_pins>;
+       mtd-mac-address = <&factory 0x28>;
+       mediatek,portmap = "llllw";
+};
index 016e5acc5906766f14fdf1f4761776e010b7889f..63d5a7c00afa74271cf1bc6aed449b48d604e952 100644 (file)
@@ -325,10 +325,17 @@ TARGET_DEVICES += psg1208
 define Device/psg1218
   DTS := PSG1218
   DEVICE_TITLE := Phicomm PSG1218
 define Device/psg1218
   DTS := PSG1218
   DEVICE_TITLE := Phicomm PSG1218
-  DEVICE_PACKAGES := kmod-mt76
+  DEVICE_PACKAGES := kmod-mt76x2
 endef
 TARGET_DEVICES += psg1218
 
 endef
 TARGET_DEVICES += psg1218
 
+define Device/psg1218k2c
+  DTS := PSG1218K2C
+  DEVICE_TITLE := Phicomm PSG1218K2C
+  DEVICE_PACKAGES := kmod-mt76x2
+endef
+TARGET_DEVICES += psg1218k2c
+
 define Device/rp-n53
   DTS := RP-N53
   DEVICE_TITLE := Asus RP-N53
 define Device/rp-n53
   DTS := RP-N53
   DEVICE_TITLE := Asus RP-N53