lantiq: fix building AVM/EVA sysupgrade images on NOR devices
authorMartin Blumenstingl <martin.blumenstingl@googlemail.com>
Sun, 21 Aug 2016 15:01:33 +0000 (17:01 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 22 Aug 2016 05:43:11 +0000 (07:43 +0200)
Device/AVM unconditionally inherits Device/NAND, which changes the
sysupgrade image to sysupgrade-tar (instead of a "raw" sysupgrade image
as used in the Device/Default template).
This moves the Device/NAND call to the FRITZ3370 device definition, as
this is the only AVM/EVA device that uses NAND.
Additionally we have to define the IMAGE_SIZE for the AVM/EVA NOR
devices to ensure that the images are not discarded.

Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
target/linux/lantiq/image/Makefile

index 3c3318d520017488ec8ab44ef8d17ce799e36098..3c7391808dde56ea9c7a9b456f505f7b37c97c56 100644 (file)
@@ -219,7 +219,6 @@ define Device/lantiqFullImage
 endef
 
 define Device/AVM
-  $(Device/NAND)
   KERNEL := kernel-bin | append-dtb | lzma | eva-image
 endef
 
@@ -523,6 +522,7 @@ TARGET_DEVICES += WBMRB
 
 define Device/FRITZ7320
   $(Device/AVM)
+  IMAGE_SIZE := 15744k
   DEVICE_TITLE := 1&1 HomeServer - FRITZ7320
   DEVICE_PACKAGES := kmod-ath9k wpad-mini \
        kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
@@ -611,6 +611,7 @@ TARGET_DEVICES += EASY80920NOR
 
 define Device/FRITZ3370
   $(Device/AVM)
+  $(Device/NAND)
   DEVICE_TITLE := Fritz!Box WLan - FRITZ3370
   DEVICE_PACKAGES := kmod-ath9k wpad-mini kmod-usb-dwc2
 endef
@@ -618,6 +619,7 @@ TARGET_DEVICES += FRITZ3370
 
 define Device/FRITZ7360SL
   $(Device/AVM)
+  IMAGE_SIZE := 15744k
   DEVICE_TITLE := 1&1 HomeServer - FRITZ7360SL
   DEVICE_PACKAGES := kmod-ath9k wpad-mini kmod-usb-dwc2
 endef