toolchain: enable parallel build for uClibc, remove the obsolete TOOLCHAIN_PARALLEL...
authorFelix Fietkau <nbd@openwrt.org>
Wed, 17 Oct 2012 13:03:08 +0000 (13:03 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 17 Oct 2012 13:03:08 +0000 (13:03 +0000)
SVN-Revision: 33807

Config.in
include/toolchain-build.mk
toolchain/uClibc/Makefile
toolchain/uClibc/common.mk

index c023d607937e0ab20e10b40cbe52c18c5a5e3a1f..cca5a4c0f0cc37b0e12ccf92778a4cd9cec723ac 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -495,20 +495,6 @@ menu "Global build settings"
                  Only say Y, if you don't mind fixing broken packages.
                  Before reporting build bugs, set this to N and re-run the build.
 
                  Only say Y, if you don't mind fixing broken packages.
                  Before reporting build bugs, set this to N and re-run the build.
 
-       config TOOLCHAIN_PARALLEL
-               bool
-               prompt "Parallelize the toolchain build (May break build)"
-               depends on PKG_BUILD_PARALLEL
-               depends on BROKEN
-               default n
-               help
-                 Build the toolchain with parallel make jobs.
-                 This speeds up the toolchain build on SMP machines, but may
-                 break the build for certain toolchain versions.
-
-                 If you say Y, toolchain build might break.
-                 Before reporting build bugs, set this to N and re-run the build.
-
        comment "Stripping options"
 
        choice
        comment "Stripping options"
 
        choice
index d2fdb0281a104175bb24649703415b30218ddd65..a86f6aba7719b78900af055e4be9bce4bae26093 100644 (file)
@@ -11,8 +11,6 @@ REAL_STAGING_DIR_HOST:=$(STAGING_DIR_HOST)
 STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
 BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
 
 STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
 BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
 
-TOOLCHAIN_JOBS?=$(if $(CONFIG_TOOLCHAIN_PARALLEL),-j$(CONFIG_PKG_BUILD_JOBS))
-
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared
index 0c2dcd3837323e06cd3db8bb2239396cbf7060e7..545ea5ae563e420e93ce770d52feae06af36678b 100644 (file)
@@ -5,6 +5,8 @@ include ./common.mk
 HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.built
 HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.uclibc_installed
 
 HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.built
 HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.uclibc_installed
 
+HOST_BUILD_PARALLEL:=1
+
 define Host/SetToolchainInfo
        $(SED) 's,^\(LIBC_TYPE\)=.*,\1=$(PKG_NAME),' $(TOOLCHAIN_DIR)/info.mk
        $(SED) 's,^\(LIBC_URL\)=.*,\1=http://www.uclibc.org/,' $(TOOLCHAIN_DIR)/info.mk
 define Host/SetToolchainInfo
        $(SED) 's,^\(LIBC_TYPE\)=.*,\1=$(PKG_NAME),' $(TOOLCHAIN_DIR)/info.mk
        $(SED) 's,^\(LIBC_URL\)=.*,\1=http://www.uclibc.org/,' $(TOOLCHAIN_DIR)/info.mk
index 5f3bd29444f2a5460e7620511f1582e74a4a7c4f..f32ed9872924502f46b9683e585a6171fd548d56 100644 (file)
@@ -50,7 +50,7 @@ CPU_CFLAGS = \
        -Wno-unused-but-set-variable \
        $(TARGET_CFLAGS)
 
        -Wno-unused-but-set-variable \
        $(TARGET_CFLAGS)
 
-UCLIBC_MAKE = PATH='$(TOOLCHAIN_DIR)/initial/bin:$(TARGET_PATH)' $(MAKE) -C $(HOST_BUILD_DIR) \
+UCLIBC_MAKE = PATH='$(TOOLCHAIN_DIR)/initial/bin:$(TARGET_PATH)' $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) \
        $(TARGET_CONFIGURE_OPTS) \
        DEVEL_PREFIX=/ \
        RUNTIME_PREFIX=/ \
        $(TARGET_CONFIGURE_OPTS) \
        DEVEL_PREFIX=/ \
        RUNTIME_PREFIX=/ \