trusted-firmware-a.mk: fix build with binutils 2.39+
authorLinhui Liu <liulinhui36@gmail.com>
Tue, 17 Jan 2023 01:27:38 +0000 (09:27 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 21 Jan 2023 10:55:23 +0000 (11:55 +0100)
Starting from version 2.39 binutils now warns about sections with rwx
permissions. While this is generally desirable it breaks building
ARM TrustedFirmware-A bl2 which treats warnings as errors.
Disable the warning/error for now to fix build.

Reference: 0579d9f5bc4b3a3d1b32526c71a6b77c4888bfcb

Signed-off-by: Linhui Liu <liulinhui36@gmail.com>
include/trusted-firmware-a.mk

index 082ada269c895bf7a95a68b06c3db33162d58d0e..0c0118e092bec5b76d602a97fdaa426cc18b15ac 100644 (file)
@@ -81,7 +81,7 @@ define Build/Compile/Trusted-Firmware-A
                $(if $(DTC),DTC="$(DTC)") \
                PLAT=$(PLAT) \
                BUILD_STRING="OpenWrt v$(PKG_VERSION)-$(PKG_RELEASE) ($(VARIANT))" \
-               $(if $(CONFIG_BINUTILS_VERSION_2_39),LDFLAGS="-no-warn-rwx-segments") \
+               $(if $(CONFIG_BINUTILS_VERSION_2_37)$(CONFIG_BINUTILS_VERSION_2_38),,LDFLAGS="-no-warn-rwx-segments") \
                $(TFA_MAKE_FLAGS)
 endef