wwan: Double quote to prevent globbing and word splitting
authorFlorian Eckert <fe@dev.tdt.de>
Tue, 29 Aug 2017 09:10:48 +0000 (11:10 +0200)
committerJo-Philipp Wich <jo@mein.io>
Fri, 18 Oct 2019 17:48:41 +0000 (19:48 +0200)
Fix some shellcheck warnings.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
[bump PKG_RELEASE]
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/network/utils/wwan/Makefile
package/network/utils/wwan/files/wwan.sh

index fddfe4054a539b226422d7533f0f9f0d9acf10b7..bb829b5e2c31f2b21c5ab5e11952fb42cb30c6db 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wwan
 PKG_VERSION:=2019-04-29
-PKG_RELEASE=3
+PKG_RELEASE=4
 
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=
index 4843b1dd4746db278e4c3fa35b09b835f8b500d0..1ffb94a92b8c59f09fffb7547019fdce370e5689 100755 (executable)
@@ -77,10 +77,10 @@ proto_wwan_setup() {
 
                json_set_namespace wwan old_cb
                json_init
-               json_load "$(cat $usb)"
+               json_load "$(cat "$usb")"
                json_select
                json_get_vars desc control data
-               json_set_namespace $old_cb
+               json_set_namespace "$old_cb"
 
                [ -n "$control" -a -n "$data" ] && {
                        ttys=$(ls -d /sys/bus/usb/devices/$devicename/${devicename}*/tty?* /sys/bus/usb/devices/$devicename/${devicename}*/tty/tty?* | sed "s/.*\///g" | tr "\n" " ")
@@ -115,9 +115,9 @@ proto_wwan_setup() {
                return 1
        }
 
-       uci_set_state network $interface driver "$driver"
-       uci_set_state network $interface ctl_device "$ctl_device"
-       uci_set_state network $interface dat_device "$dat_device"
+       uci_set_state network "$interface" driver "$driver"
+       uci_set_state network "$interface" ctl_device "$ctl_device"
+       uci_set_state network "$interface" dat_device "$dat_device"
 
        case $driver in
        qmi_wwan)               proto_qmi_setup $@ ;;
@@ -130,9 +130,9 @@ proto_wwan_setup() {
 
 proto_wwan_teardown() {
        local interface=$1
-       local driver=$(uci_get_state network $interface driver)
-       ctl_device=$(uci_get_state network $interface ctl_device)
-       dat_device=$(uci_get_state network $interface dat_device)
+       local driver=$(uci_get_state network "$interface" driver)
+       ctl_device=$(uci_get_state network "$interface" ctl_device)
+       dat_device=$(uci_get_state network "$interface" dat_device)
 
        case $driver in
        qmi_wwan)               proto_qmi_teardown $@ ;;