ath79: add tl-mr3020-v1 support
authorLucian Cristian <lucian.cristian@gmail.com>
Fri, 8 Jun 2018 08:51:00 +0000 (11:51 +0300)
committerJohn Crispin <john@phrozen.org>
Fri, 8 Jun 2018 10:19:49 +0000 (12:19 +0200)
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/dts/ar9331.dtsi
target/linux/ath79/dts/ar9331_tl-mr3020-v1.dts [new file with mode: 0644]
target/linux/ath79/dts/ar9331_tl_mr3020.dts [deleted file]
target/linux/ath79/image/tiny-tp-link.mk

index 80e32d9e0036dfe50c610883f92d0fe1c9bdc1f8..0ba03b25a0129e6502dd76370f76d69217e01286 100755 (executable)
@@ -27,6 +27,9 @@ case "$board" in
 "glinet,ar150")
        ucidef_set_led_wlan "wlan" "WLAN" "gl-ar150:orange:wlan" "phy0tpt"
        ;;
 "glinet,ar150")
        ucidef_set_led_wlan "wlan" "WLAN" "gl-ar150:orange:wlan" "phy0tpt"
        ;;
+"tplink,tl-mr3020-v1")
+       ucidef_set_led_switch "lan" "LAN" "tp-link:green:lan" "switch0" "0x02"
+       ;;
 "tplink,tl-wr740n-v2")
        ucidef_set_led_netdev "wan" "WAN" "$boardname:green:wan" "eth0"
        ucidef_set_led_switch "lan1" "LAN1" "$boardname:green:lan1" "switch0" "0x02"
 "tplink,tl-wr740n-v2")
        ucidef_set_led_netdev "wan" "WAN" "$boardname:green:wan" "eth0"
        ucidef_set_led_switch "lan1" "LAN1" "$boardname:green:lan1" "switch0" "0x02"
index a2d6ab00492cd3000417780e83d6b136fd7d4844..8e3c9177a221354e5295b3512cafd021af305a49 100755 (executable)
@@ -26,7 +26,10 @@ ath79_setup_interfaces()
        "glinet,ar150")
                ucidef_set_interfaces_lan_wan "eth1" "eth0"
                ;;
        "glinet,ar150")
                ucidef_set_interfaces_lan_wan "eth1" "eth0"
                ;;
-               
+       "tplink,tl-mr3020-v1")
+               ucidef_set_interface_lan "eth0.1"
+               ucidef_add_switch "switch0" "0@eth0" "1:lan"
+               ;;
        "tplink,tl-wdr3600"|\
        "tplink,tl-wdr4300")
                ucidef_add_switch "switch0" \
        "tplink,tl-wdr3600"|\
        "tplink,tl-wdr4300")
                ucidef_add_switch "switch0" \
index b29c88a958f70bd644752d28a71b3c0d5f5446e3..5ce755a5924206fe3f4f07ec0b811e6632197ac5 100644 (file)
@@ -3,4 +3,9 @@
 
 / {
        compatible = "qca,ar9331";
 
 / {
        compatible = "qca,ar9331";
+
+       ref: ref {
+               compatible = "fixed-clock";
+               #clock-cells = <0>;
+       };
 };
 };
diff --git a/target/linux/ath79/dts/ar9331_tl-mr3020-v1.dts b/target/linux/ath79/dts/ar9331_tl-mr3020-v1.dts
new file mode 100644 (file)
index 0000000..fc81015
--- /dev/null
@@ -0,0 +1,192 @@
+// SPDX-License-Identifier: GPL-2.0
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar9331.dtsi"
+
+/ {
+       model = "TP-Link TL-MR3020 V1";
+       compatible = "tplink,tl-mr3020-v1", "qca,ar9331";
+
+       aliases {
+               serial0 = &uart;
+               led-status = &system;
+       };
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x2000000>;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               wlan {
+                       label = "tp-link:green:wlan";
+                       gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
+                       default-state = "off";
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               lan {
+                       label = "tp-link:green:lan";
+                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               system: wps {
+                       label = "tp-link:green:wps";
+                       gpios = <&gpio 26 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+               };
+
+               led3g {
+                       label = "tp-link:green:3g";
+                       gpios = <&gpio 27 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       trigger-sources = <&hub_port>;
+                       linux,default-trigger = "usbport";
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+               #address-cells = <1>;
+               #size-cells = <0>;
+
+               button0 {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 11 GPIO_ACTIVE_HIGH>;
+                       debounce-interval = <60>;
+               };
+
+               button1 {
+                       label = "sw1";
+                       linux,input-type = <EV_SW>;
+                       linux,code = <BTN_0>;
+                       gpios = <&gpio 18 GPIO_ACTIVE_HIGH>;
+                       debounce-interval = <60>;
+               };
+
+               button2 {
+                       label = "sw2";
+                       linux,input-type = <EV_SW>;
+                       linux,code = <BTN_1>;
+                       gpios = <&gpio 20 GPIO_ACTIVE_HIGH>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       reg_usb_vbus: reg_usb_vbus {
+               compatible = "regulator-fixed";
+               regulator-name = "usb_vbus";
+               regulator-min-microvolt = <5000000>;
+               regulator-max-microvolt = <5000000>;
+               gpio = <&gpio 8 GPIO_ACTIVE_HIGH>;
+               enable-active-high;
+       };
+};
+
+&ref {
+       clock-frequency = <25000000>;
+};
+
+&uart {
+       status = "okay";
+};
+
+&gpio {
+       status = "okay";
+};
+
+&usb {
+       dr_mode = "host";
+       vbus-supply = <&reg_usb_vbus>;
+       status = "okay";
+
+       hub_port: port@1 {
+               reg = <1>;
+               #trigger-source-cells = <0>;
+       };
+};
+
+&usb_phy {
+       status = "okay";
+};
+
+&spi {
+       num-chipselects = <1>;
+       status = "okay";
+
+       /* Spansion S25FL032PIF SPI flash */
+       spiflash: s25sl032p@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               spi-max-frequency = <104000000>;
+               reg = <0>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       uboot:  partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x020000>;
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               label = "firmware";
+                               reg = <0x020000 0x3c0000>;
+                       };
+
+                       partition@3e0000 {
+                               label = "config";
+                               reg = <0x3e0000 0x010000>;
+                               read-only;
+                       };
+
+                       art: partition@3f0000 {
+                               label = "art";
+                               reg = <0x3f0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&mdio1 {
+       status = "okay";
+       phy4: ethernet-phy@4 {
+               reg = <4>;
+       };
+};
+
+&eth1 {
+       status = "okay";
+       phy-handle = <&phy4>;
+
+       mtd-mac-address = <&uboot 0x1fc00>;
+       fixed-link {
+               speed = <1000>;
+               full-duplex;
+       };
+
+       gmac-config {
+               device = <&gmac>;
+
+               switch-phy-addr-swap = <1>;
+               switch-phy-swap = <1>;
+       };
+};
+
+&wmac {
+       status = "okay";
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&uboot 0x1fc00>;
+};
diff --git a/target/linux/ath79/dts/ar9331_tl_mr3020.dts b/target/linux/ath79/dts/ar9331_tl_mr3020.dts
deleted file mode 100644 (file)
index 34ee805..0000000
+++ /dev/null
@@ -1,119 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0
-/dts-v1/;
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "ar9331.dtsi"
-
-/ {
-       model = "TP-Link TL-MR3020";
-       compatible = "tplink,tl-mr3020", "qca,ar9331";
-
-       aliases {
-               serial0 = &uart;
-       };
-
-       memory@0 {
-               device_type = "memory";
-               reg = <0x0 0x2000000>;
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               wlan {
-                       label = "tp-link:green:wlan";
-                       gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
-                       default-state = "off";
-               };
-
-               lan {
-                       label = "tp-link:green:lan";
-                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
-                       default-state = "off";
-               };
-
-               wps {
-                       label = "tp-link:green:wps";
-                       gpios = <&gpio 26 GPIO_ACTIVE_LOW>;
-                       default-state = "off";
-               };
-
-               led3g {
-                       label = "tp-link:green:3g";
-                       gpios = <&gpio 27 GPIO_ACTIVE_LOW>;
-                       default-state = "off";
-               };
-       };
-
-       keys {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <100>;
-
-               button@0 {
-                       label = "wps";
-                       linux,code = <KEY_WPS_BUTTON>;
-                       gpios = <&gpio 11 GPIO_ACTIVE_HIGH>;
-               };
-
-               button@1 {
-                       label = "sw1";
-                       linux,code = <BTN_0>;
-                       gpios = <&gpio 18 GPIO_ACTIVE_HIGH>;
-               };
-
-               button@2 {
-                       label = "sw2";
-                       linux,code = <BTN_1>;
-                       gpios = <&gpio 20 GPIO_ACTIVE_HIGH>;
-               };
-       };
-
-       reg_usb_vbus: reg_usb_vbus {
-               compatible = "regulator-fixed";
-               regulator-name = "usb_vbus";
-               regulator-min-microvolt = <5000000>;
-               regulator-max-microvolt = <5000000>;
-               gpio = <&gpio 8 GPIO_ACTIVE_HIGH>;
-               enable-active-high;
-       };
-};
-
-&ref {
-       clock-frequency = <25000000>;
-};
-
-&uart {
-       status = "okay";
-};
-
-&gpio {
-       status = "okay";
-};
-
-&usb {
-       dr_mode = "host";
-       vbus-supply = <&reg_usb_vbus>;
-       status = "okay";
-};
-
-&usb_phy {
-       status = "okay";
-};
-
-&spi {
-       num-chipselects = <1>;
-       status = "okay";
-
-       /* Spansion S25FL032PIF SPI flash */
-       spiflash: s25sl032p@0 {
-               #address-cells = <1>;
-               #size-cells = <1>;
-               compatible = "spansion,s25sl032p", "jedec,spi-nor";
-               spi-max-frequency = <104000000>;
-               reg = <0>;
-       };
-};
index f92c7d9644e20483f5def5612fb2a75cdf870b58..1dfed48dbad4b182853d89374b6c144573ebdcd2 100644 (file)
@@ -11,6 +11,16 @@ define Device/tl-mr10u
 endef
 TARGET_DEVICES += tl-mr10u
 
 endef
 TARGET_DEVICES += tl-mr10u
 
+define Device/tl-mr3020-v1
+  $(Device/tplink-4mlzma)
+  ATH_SOC := ar9331
+  DEVICE_TITLE := TP-LINK TL-MR3020 v1
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-chipidea2 kmod-usb-ledtrig-usbport
+  TPLINK_HWID := 0x30200001
+  SUPPORTED_DEVICES := tplink,tl-mr3020-v1 tl-mr3020-v1
+endef
+TARGET_DEVICES += tl-mr3020-v1
+
 define Device/tl-wr703n
   $(Device/tplink-4mlzma)
   ATH_SOC := ar9331
 define Device/tl-wr703n
   $(Device/tplink-4mlzma)
   ATH_SOC := ar9331