lantiq: ltq-ifxos: Do not force O3 build any more
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 2 Mar 2018 23:22:49 +0000 (00:22 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 2 Mar 2018 23:53:35 +0000 (00:53 +0100)
Do not force to build with O3 optimization any more, but take what was
selected by the OpenWrt build system.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/lantiq/ltq-ifxos/Makefile
package/kernel/lantiq/ltq-ifxos/patches/020-no-O3.patch [new file with mode: 0644]
package/kernel/lantiq/ltq-ifxos/patches/200-Fix-app-compilation-failure-from-inclusion-of-wrong-.patch

index 43eb53c5427dc3bce87d577ce1fafdc1c43005a8..bd4f08da8366353087f5d234e5a859720cc5def5 100644 (file)
@@ -8,7 +8,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=lib_ifxos
 PKG_VERSION:=1.5.19
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=https://github.com/xdarklight/$(PKG_NAME)/archive/v$(PKG_VERSION)
diff --git a/package/kernel/lantiq/ltq-ifxos/patches/020-no-O3.patch b/package/kernel/lantiq/ltq-ifxos/patches/020-no-O3.patch
new file mode 100644 (file)
index 0000000..d2e816f
--- /dev/null
@@ -0,0 +1,19 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -45,8 +45,6 @@ endif !HAVE_GCC
+ if ENABLE_DEBUG
+ used_gcc_cflags += -O1 -g
+-else
+-used_gcc_cflags += -O3
+ endif
+ AM_CFLAGS = \
+@@ -92,7 +90,6 @@ endif
+ drvifxos_additional_cflags=\
+       -DLINUX \
+       -D__LINUX__ \
+-      -O \
+       -D__KERNEL__ \
+       -DMODULE \
+       -DEXPORT_SYMTAB
index dee3482e4f23307b4ec79846d473a3baad780661..5d661db861458982922e0104e0b8485725bb590d 100644 (file)
@@ -37,8 +37,6 @@ Ref: https://bugs.lede-project.org/index.php?do=details&task_id=1196
  src/Makefile.am | 6 +-----
  1 file changed, 1 insertion(+), 5 deletions(-)
 
-diff --git a/src/Makefile.am b/src/Makefile.am
-index f95668f..d232e7f 100644
 --- a/src/Makefile.am
 +++ b/src/Makefile.am
 @@ -14,11 +14,7 @@ lib_LIBRARIES = libifxos.a
@@ -54,6 +52,3 @@ index f95668f..d232e7f 100644
  
  if HAVE_GCC
  
--- 
-1.8.3.1
-