kernel: Make kmod-mpls depend on iptunnel in kernel 4.19
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 2 Nov 2018 23:28:52 +0000 (00:28 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 15 Dec 2018 13:28:49 +0000 (14:28 +0100)
This new dependency is needed with kernel 4.19.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/netsupport.mk

index f94c20d..f84047b 100644 (file)
@@ -1017,7 +1017,7 @@ $(eval $(call KernelPackage,rxrpc))
 define KernelPackage/mpls
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=MPLS support
-  DEPENDS:=@!LINUX_3_18
+  DEPENDS:=@!LINUX_3_18 +LINUX_4_19:kmod-iptunnel
   KCONFIG:= \
        CONFIG_MPLS=y \
        CONFIG_LWTUNNEL=y \