tools/findutils: update to 4.9.0
authorRosen Penev <rosenp@gmail.com>
Mon, 21 Feb 2022 23:47:13 +0000 (15:47 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 28 Feb 2022 23:08:08 +0000 (00:08 +0100)
Add compilation fix for Ubuntu 20.04. Provided by upstream maintainer:

https://github.com/openwrt/packages/issues/17912#issuecomment-1046726426

Signed-off-by: Rosen Penev <rosenp@gmail.com>
tools/findutils/Makefile
tools/findutils/patches/010-endpwent.patch [new file with mode: 0644]

index 37cd897355c3c13e799f19437bb1cd01af6ba465..d0d780689ba147aa8756dc31494857ae8d57ccfc 100644 (file)
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=findutils
 PKG_CPE_ID:=cpe:/a:gnu:findutils
-PKG_VERSION:=4.8.0
+PKG_VERSION:=4.9.0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_HASH:=57127b7e97d91282c6ace556378d5455a9509898297e46e10443016ea1387164
+PKG_HASH:=a2bfb8c09d436770edc59f50fa483e785b161a3b7b9d547573cb08065fd462fe
 
 HOST_BUILD_PARALLEL:=1
 
diff --git a/tools/findutils/patches/010-endpwent.patch b/tools/findutils/patches/010-endpwent.patch
new file mode 100644 (file)
index 0000000..dc346f3
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/find/parser.c
++++ b/find/parser.c
+@@ -67,12 +67,12 @@
+ #include "findutils-version.h"
+ #include "system.h"
+-
+-#ifndef HAVE_ENDGRENT
+-# define endgrent ()
++#if ! HAVE_ENDGRENT
++# define endgrent() ((void) 0)
+ #endif
+-#ifndef HAVE_ENDPWENT
+-# define endpwent ()
++
++#if ! HAVE_ENDPWENT
++# define endpwent() ((void) 0)
+ #endif
+ static bool parse_accesscheck   (const struct parser_table*, char *argv[], int *arg_ptr);