kernel: bump 4.14 to 4.14.139
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 16 Aug 2019 10:05:22 +0000 (12:05 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 27 Aug 2019 08:39:49 +0000 (10:39 +0200)
Refreshed all patches.

Also add a missing symbol for x86 which got used now in this bump.
- ISCSI_IBFT

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/hack-4.14/902-debloat_proc.patch
target/linux/x86/64/config-default
target/linux/x86/generic/config-default
target/linux/x86/geode/config-default
target/linux/x86/legacy/config-default

index ed7486070208e1eefb59a2b7e3ccee0733faa929..37c48bdad6b42c1ed04e8e4e74714928731e4c8a 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .189
-LINUX_VERSION-4.14 = .138
+LINUX_VERSION-4.14 = .139
 
 LINUX_KERNEL_HASH-4.9.189 = 93d945661246f726b694455c80c140717d2beff5a718445a51183439bbe5d0b3
-LINUX_KERNEL_HASH-4.14.138 = f250bd1de3a83c1f015f8e6e9bfa9f20eaef3dc24a6cd60116e49979314b837b
+LINUX_KERNEL_HASH-4.14.139 = 8c62d495444dba90200740ec770d274780b010e957cfc447f07999d717e37042
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 72ee9c011ee046e4eca782df6291c6a4e1dfbdc6..f75b9721e5b06d5c0754e0630282dbee59cf7fe9 100644 (file)
@@ -233,7 +233,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                return -ENOMEM;
 --- a/mm/vmalloc.c
 +++ b/mm/vmalloc.c
-@@ -2774,6 +2774,8 @@ static const struct file_operations proc
+@@ -2783,6 +2783,8 @@ static const struct file_operations proc
  
  static int __init proc_vmalloc_init(void)
  {
index ee14a3657310da5f19671e3a808b8b4ae0e59634..f4569c4214c2737cf44735a5217f711e3b3b3269 100644 (file)
@@ -221,6 +221,7 @@ CONFIG_INTEL_SOC_DTS_THERMAL=y
 # CONFIG_IOMMU_DEBUG is not set
 CONFIG_IOSF_MBI=y
 # CONFIG_IOSF_MBI_DEBUG is not set
+# CONFIG_ISCSI_IBFT is not set
 # CONFIG_ISCSI_IBFT_FIND is not set
 CONFIG_KALLSYMS_ABSOLUTE_PERCPU=y
 # CONFIG_KVM_DEBUG_FS is not set
index 1e7cea801f39092cb4b415d1eec2ea8c704b314f..1e32581848d14d82aaec2890bbfa492a28e352d9 100644 (file)
@@ -217,6 +217,7 @@ CONFIG_IRQ_BYPASS_MANAGER=y
 CONFIG_ISA=y
 CONFIG_ISAPNP=y
 CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
 # CONFIG_ISCSI_IBFT_FIND is not set
 CONFIG_ISO9660_FS=y
 # CONFIG_JOLIET is not set
index abca7ac6b81473b81937c4bcb89e5d25f6d9f656..2861c2bc356fedf2be998c8e18fdaa0d065e4171 100644 (file)
@@ -74,6 +74,7 @@ CONFIG_IOSF_MBI=y
 CONFIG_ISA=y
 # CONFIG_ISAPNP is not set
 CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
 # CONFIG_ISCSI_IBFT_FIND is not set
 # CONFIG_LANCE is not set
 CONFIG_LEDS_GPIO=y
index d1a4e810352ca62eb138bf7dab57a6afc4583c40..60191c935cccfa18418723d0d53de6f28480aee5 100644 (file)
@@ -137,6 +137,7 @@ CONFIG_IOSF_MBI=y
 CONFIG_ISA=y
 CONFIG_ISAPNP=y
 CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
 # CONFIG_ISCSI_IBFT_FIND is not set
 CONFIG_ISO9660_FS=y
 # CONFIG_JOLIET is not set