kernel: bump 4.19 to 4.19.23
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 15 Feb 2019 10:09:35 +0000 (11:09 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 15 Feb 2019 20:53:27 +0000 (21:53 +0100)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.19/048-v4.21-mtd-improve-calculating-partition-boundaries-when-ch.patch
target/linux/generic/pending-4.19/400-mtd-add-rootfs-split-support.patch
target/linux/generic/pending-4.19/401-mtd-add-support-for-different-partition-parser-types.patch
target/linux/generic/pending-4.19/402-mtd-use-typed-mtd-parsers-for-rootfs-and-firmware-split.patch
target/linux/generic/pending-4.19/404-mtd-add-more-helper-functions.patch
target/linux/generic/pending-4.19/411-mtd-partial_eraseblock_write.patch
target/linux/generic/pending-4.19/834-ledtrig-libata.patch

index af7b5cd8a76385fc3bf5136add6c2eaa37782434..9c0d8f1a0c73640d05055f256c47c6ed04926555 100644 (file)
@@ -5,12 +5,12 @@ LINUX_RELEASE?=1
 LINUX_VERSION-3.18 = .134
 LINUX_VERSION-4.9 = .158
 LINUX_VERSION-4.14 = .101
 LINUX_VERSION-3.18 = .134
 LINUX_VERSION-4.9 = .158
 LINUX_VERSION-4.14 = .101
-LINUX_VERSION-4.19 = .21
+LINUX_VERSION-4.19 = .23
 
 LINUX_KERNEL_HASH-3.18.134 = 36bdd04cab3b6c824a4b7e32ae02503f437e0916d5a4ff04c90aa22da2749c2f
 LINUX_KERNEL_HASH-4.9.158 = 8c8a69f590e6f1103c949b45ff1bfd42c705388321f75e1520be3556f81375ef
 LINUX_KERNEL_HASH-4.14.101 = 142ff7c51b001c66e9be134fcec2722f9a47b89879a18e6f65b09b4585cdb69a
 
 LINUX_KERNEL_HASH-3.18.134 = 36bdd04cab3b6c824a4b7e32ae02503f437e0916d5a4ff04c90aa22da2749c2f
 LINUX_KERNEL_HASH-4.9.158 = 8c8a69f590e6f1103c949b45ff1bfd42c705388321f75e1520be3556f81375ef
 LINUX_KERNEL_HASH-4.14.101 = 142ff7c51b001c66e9be134fcec2722f9a47b89879a18e6f65b09b4585cdb69a
-LINUX_KERNEL_HASH-4.19.21 = db08ede726fe410da274e1e98f0de2aed9ff4b0e0b63a89e5928bef46998bbc1
+LINUX_KERNEL_HASH-4.19.23 = 2d9b25678aac7f3f109c52e6266fb6ee89cc424b597518a2875874bacb8f130a
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 9bd07186d3bf12c197300e3a57fc0a1dba2f68ba..02296276b0991a0afd7aaf7f49b6632a8ad912d4 100644 (file)
@@ -35,7 +35,7 @@ Signed-off-by: Boris Brezillon <boris.brezillon@bootlin.com>
  
  /*
   * MTD methods which simply translate the effective address and pass through
  
  /*
   * MTD methods which simply translate the effective address and pass through
-@@ -514,7 +523,7 @@ static struct mtd_part *allocate_partiti
+@@ -518,7 +527,7 @@ static struct mtd_part *allocate_partiti
        if (!(slave->mtd.flags & MTD_NO_ERASE))
                wr_alignment = slave->mtd.erasesize;
  
        if (!(slave->mtd.flags & MTD_NO_ERASE))
                wr_alignment = slave->mtd.erasesize;
  
@@ -44,7 +44,7 @@ Signed-off-by: Boris Brezillon <boris.brezillon@bootlin.com>
        remainder = do_div(tmp, wr_alignment);
        if ((slave->mtd.flags & MTD_WRITEABLE) && remainder) {
                /* Doesn't start on a boundary of major erase size */
        remainder = do_div(tmp, wr_alignment);
        if ((slave->mtd.flags & MTD_WRITEABLE) && remainder) {
                /* Doesn't start on a boundary of major erase size */
-@@ -525,7 +534,7 @@ static struct mtd_part *allocate_partiti
+@@ -529,7 +538,7 @@ static struct mtd_part *allocate_partiti
                        part->name);
        }
  
                        part->name);
        }
  
index 6fdd0267c11a130142691a9c392169f229d840b7..e646224df28f045da678eacec4aca9825c38571c 100644 (file)
@@ -59,7 +59,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  /*
   * Given a pointer to the MTD object in the mtd_part structure, we can retrieve
   * the pointer to that structure.
  /*
   * Given a pointer to the MTD object in the mtd_part structure, we can retrieve
   * the pointer to that structure.
-@@ -619,6 +623,7 @@ int mtd_add_partition(struct mtd_info *p
+@@ -623,6 +627,7 @@ int mtd_add_partition(struct mtd_info *p
        mutex_unlock(&mtd_partitions_mutex);
  
        add_mtd_device(&new->mtd);
        mutex_unlock(&mtd_partitions_mutex);
  
        add_mtd_device(&new->mtd);
@@ -67,7 +67,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        mtd_add_partition_attrs(new);
  
  
        mtd_add_partition_attrs(new);
  
-@@ -697,6 +702,29 @@ int mtd_del_partition(struct mtd_info *m
+@@ -701,6 +706,29 @@ int mtd_del_partition(struct mtd_info *m
  }
  EXPORT_SYMBOL_GPL(mtd_del_partition);
  
  }
  EXPORT_SYMBOL_GPL(mtd_del_partition);
  
@@ -97,7 +97,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  /*
   * This function, given a master MTD object and a partition table, creates
   * and registers slave MTD objects which are bound to the master according to
  /*
   * This function, given a master MTD object and a partition table, creates
   * and registers slave MTD objects which are bound to the master according to
-@@ -728,6 +756,7 @@ int add_mtd_partitions(struct mtd_info *
+@@ -732,6 +760,7 @@ int add_mtd_partitions(struct mtd_info *
                mutex_unlock(&mtd_partitions_mutex);
  
                add_mtd_device(&slave->mtd);
                mutex_unlock(&mtd_partitions_mutex);
  
                add_mtd_device(&slave->mtd);
index d48447fb9ca445e1d86bb42b6333c124efc15653..4026a2050b9e5db4c36ad8986dbb463be0996793 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  
  /*
   * Given a pointer to the MTD object in the mtd_part structure, we can retrieve
  
  /*
   * Given a pointer to the MTD object in the mtd_part structure, we can retrieve
-@@ -702,6 +706,36 @@ int mtd_del_partition(struct mtd_info *m
+@@ -706,6 +710,36 @@ int mtd_del_partition(struct mtd_info *m
  }
  EXPORT_SYMBOL_GPL(mtd_del_partition);
  
  }
  EXPORT_SYMBOL_GPL(mtd_del_partition);
  
@@ -57,7 +57,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  #ifdef CONFIG_MTD_SPLIT_FIRMWARE_NAME
  #define SPLIT_FIRMWARE_NAME   CONFIG_MTD_SPLIT_FIRMWARE_NAME
  #else
  #ifdef CONFIG_MTD_SPLIT_FIRMWARE_NAME
  #define SPLIT_FIRMWARE_NAME   CONFIG_MTD_SPLIT_FIRMWARE_NAME
  #else
-@@ -1037,6 +1071,61 @@ void mtd_part_parser_cleanup(struct mtd_
+@@ -1041,6 +1075,61 @@ void mtd_part_parser_cleanup(struct mtd_
        }
  }
  
        }
  }
  
index ca9b6c3594e5fe1f5ce4264366fe3dcf2ebd3aa0..8a90ce6a8b75874fe4a10f0f20b1c60290622386 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
 
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -744,6 +744,7 @@ run_parsers_by_type(struct mtd_part *sla
+@@ -748,6 +748,7 @@ run_parsers_by_type(struct mtd_part *sla
  
  static void split_firmware(struct mtd_info *master, struct mtd_part *part)
  {
  
  static void split_firmware(struct mtd_info *master, struct mtd_part *part)
  {
@@ -18,7 +18,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  }
  
  static void mtd_partition_split(struct mtd_info *master, struct mtd_part *part)
  }
  
  static void mtd_partition_split(struct mtd_info *master, struct mtd_part *part)
-@@ -753,6 +754,12 @@ static void mtd_partition_split(struct m
+@@ -757,6 +758,12 @@ static void mtd_partition_split(struct m
        if (rootfs_found)
                return;
  
        if (rootfs_found)
                return;
  
index 82c74e27a9131d88673bf67b972227eacba31e70..2e95e99f6d1cdc4d20ecde9de3141401dfe20193 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
 
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -1150,6 +1150,24 @@ int mtd_is_partition(const struct mtd_in
+@@ -1154,6 +1154,24 @@ int mtd_is_partition(const struct mtd_in
  }
  EXPORT_SYMBOL_GPL(mtd_is_partition);
  
  }
  EXPORT_SYMBOL_GPL(mtd_is_partition);
  
index 0b5e4005ff4cc55429d4561fd84d6ca02cb074a8..bf9822fda83c6af4285df43e767f06d73e645a20 100644 (file)
@@ -98,7 +98,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        return ret;
  }
  
        return ret;
  }
  
-@@ -535,19 +602,22 @@ static struct mtd_part *allocate_partiti
+@@ -539,19 +606,22 @@ static struct mtd_part *allocate_partiti
        remainder = do_div(tmp, wr_alignment);
        if ((slave->mtd.flags & MTD_WRITEABLE) && remainder) {
                /* Doesn't start on a boundary of major erase size */
        remainder = do_div(tmp, wr_alignment);
        if ((slave->mtd.flags & MTD_WRITEABLE) && remainder) {
                /* Doesn't start on a boundary of major erase size */
index 16855201f3b68758e0fed3a5a6cb2f485cdc4221..70d3de05d0eeee26ac81d71ac5f0a94741bc1958 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -5130,6 +5143,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5131,6 +5144,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
                if (tag < 0)
                        return NULL;
        }
                if (tag < 0)
                        return NULL;
        }
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = qc->hw_tag = tag;
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = qc->hw_tag = tag;
-@@ -6040,6 +6056,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -6041,6 +6057,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
        ata_sff_port_init(ap);
  
        return ap;
-@@ -6075,6 +6094,12 @@ static void ata_host_release(struct kref
+@@ -6076,6 +6095,12 @@ static void ata_host_release(struct kref
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6538,7 +6563,23 @@ int ata_host_register(struct ata_host *h
+@@ -6539,7 +6564,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }