kernel: add dependency on kmod-crypto-authenc to kmod-ipsec (closes: #7431)
authorNicolas Thill <nico@openwrt.org>
Sat, 22 Oct 2011 10:19:27 +0000 (10:19 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 22 Oct 2011 10:19:27 +0000 (10:19 +0000)
SVN-Revision: 28515

package/kernel/modules/netsupport.mk

index b845f071cd943c4b890409ac341d7d9da66fd8d5..7862d60c36a28761315c2cff6585e0b1e3c9d2f6 100644 (file)
@@ -181,7 +181,7 @@ IPSEC-m:= \
 define KernelPackage/ipsec
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=IPsec related modules (IPv4 and IPv6)
-  DEPENDS:=+kmod-crypto-iv +kmod-crypto-des +kmod-crypto-hmac +kmod-crypto-md5 +kmod-crypto-sha1 +kmod-crypto-deflate +kmod-crypto-cbc
+  DEPENDS:=+kmod-crypto-authenc +kmod-crypto-iv +kmod-crypto-des +kmod-crypto-hmac +kmod-crypto-md5 +kmod-crypto-sha1 +kmod-crypto-deflate +kmod-crypto-cbc
   KCONFIG:= \
        CONFIG_NET_KEY \
        CONFIG_XFRM_USER \