busybox: fix empty password detection in telnetd init (#10432)
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 16 Nov 2011 13:17:35 +0000 (13:17 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 16 Nov 2011 13:17:35 +0000 (13:17 +0000)
SVN-Revision: 29183

package/busybox/Makefile
package/busybox/files/telnet

index a8bb67ac2967ff329a152839a2dc57c0cac3606e..7770a538e9b204810d6ce03a332f9194e421330b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.19.3
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 334523eb9fd4d402b2bd44601417094abae8a6e4..994e713e704fb84b173bebcc8667c9327df12a66 100755 (executable)
@@ -8,7 +8,7 @@ has_root_pwd() {
              pwd="${pwd#*root:}"
              pwd="${pwd%%:*}"
 
-       test -n "${pwd#!}"
+       test -n "${pwd#[\!x]}"
 }
 
 get_root_home() {