build: drop buildbot toolchain rebuild check when not using git
authorFelix Fietkau <nbd@nbd.name>
Mon, 24 Sep 2018 09:02:30 +0000 (11:02 +0200)
committerFelix Fietkau <nbd@nbd.name>
Mon, 24 Sep 2018 09:08:44 +0000 (11:08 +0200)
The check cleans and rebuilds the toolchain if it changed on update.
When building from a source tarball, it is reasonable to expect that
there will be no updates, so no rebuild check is necessary

Signed-off-by: Felix Fietkau <nbd@nbd.name>
toolchain/Makefile

index 409955c23a9c941387c92499f5270d69a973cdd2..e4631bc7bffe2aedba8504e527d3762678c2dc50 100644 (file)
@@ -70,6 +70,7 @@ endif
 endif
 
 ifdef CONFIG_BUILDBOT
+ifneq ($(wildcard $(TOPDIR)/.git),)
   $(TOOLCHAIN_DIR)/stamp/.ver_check: $(TMP_DIR)/.build
        cd "$(TOPDIR)"; git log --format=%h -1 toolchain > $(TMP_DIR)/.ver_check
        cmp -s $(TMP_DIR)/.ver_check $@ || { \
@@ -80,6 +81,7 @@ ifdef CONFIG_BUILDBOT
 
 $(TOOLCHAIN_DIR)/info.mk $(STAGING_DIR)/.prepared: $(TOOLCHAIN_DIR)/stamp/.ver_check
 endif
+endif
 
 # prerequisites for the individual targets
 $(curdir)/ := .config prereq