build: optimize target metadata dump
authorFelix Fietkau <nbd@openwrt.org>
Wed, 22 Oct 2014 08:57:25 +0000 (08:57 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 22 Oct 2014 08:57:25 +0000 (08:57 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 43019

include/target.mk

index f8c23759172d2c6a38021ea4cd5b851d67ca1b73..3401f849a5fdd3980b4edd938eee786d0df4eab1 100644 (file)
@@ -63,8 +63,8 @@ ifndef Profile
 define Profile
   $(eval $(call Profile/Default))
   $(eval $(call Profile/$(1)))
-  $(eval $(call shexport,Profile/$(1)/Config))
-  $(eval $(call shexport,Profile/$(1)/Description))
+  dumpinfo : $(call shexport,Profile/$(1)/Config)
+  dumpinfo : $(call shexport,Profile/$(1)/Description)
   DUMPINFO += \
        echo "Target-Profile: $(1)"; \
        echo "Target-Profile-Name: $(NAME)"; \
@@ -73,10 +73,10 @@ define Profile
                echo "Target-Profile-Kconfig: yes"; \
        fi; \
        echo "Target-Profile-Config: "; \
-       $(SH_FUNC) getvar "$(call shvar,Profile/$(1)/Config)"; \
+       echo "$$$$$$$$$(call shvar,Profile/$(1)/Config)"; \
        echo "@@"; \
        echo "Target-Profile-Description:"; \
-       $(SH_FUNC) getvar "$(call shvar,Profile/$(1)/Description)"; \
+       echo "$$$$$$$$$(call shvar,Profile/$(1)/Description)"; \
        echo "@@"; \
        echo;
   ifeq ($(CONFIG_TARGET_$(call target_conf,$(BOARD)_$(if $(SUBTARGET),$(SUBTARGET)_))$(1)),y)
@@ -104,8 +104,6 @@ else
   endif
 endif
 
-$(eval $(call shexport,Target/Description))
-
 ifneq ($(TARGET_BUILD)$(if $(DUMP),,1),)
   include $(INCLUDE_DIR)/kernel-version.mk
 endif
@@ -259,6 +257,7 @@ endif
 
 define BuildTargets/DumpCurrent
   .PHONY: dumpinfo
+  dumpinfo : export DESCRIPTION=$$(Target/Description)
   dumpinfo:
        @echo 'Target: $(TARGETID)'; \
         echo 'Target-Board: $(BOARD)'; \
@@ -273,9 +272,9 @@ define BuildTargets/DumpCurrent
         echo 'Linux-Version: $(LINUX_VERSION)'; \
         echo 'Linux-Release: $(LINUX_RELEASE)'; \
         echo 'Linux-Kernel-Arch: $(LINUX_KARCH)'; \
-       $(if $(SUBTARGET),,$(if $(DEFAULT_SUBTARGET), echo 'Default-Subtarget: $(DEFAULT_SUBTARGET)'; ))
+       $(if $(SUBTARGET),,$(if $(DEFAULT_SUBTARGET), echo 'Default-Subtarget: $(DEFAULT_SUBTARGET)'; )) \
         echo 'Target-Description:'; \
-        $(SH_FUNC) getvar $(call shvar,Target/Description); \
+        echo "$$$$DESCRIPTION"; \
         echo '@@'; \
         echo 'Default-Packages: $(DEFAULT_PACKAGES) $(call extra_packages,$(DEFAULT_PACKAGES))'; \
         $(DUMPINFO)