kernel: fix usage of CompareKernelPatchVer for kmod-gre
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 10 Mar 2011 14:30:05 +0000 (14:30 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 10 Mar 2011 14:30:05 +0000 (14:30 +0000)
SVN-Revision: 26010

package/kernel/modules/netsupport.mk

index 8379931f1a839d3c4f8b43dacad0ae15ebdd2f9a..25e2ac42c21c5fc0b90105b1735681d0cdead45b 100644 (file)
@@ -371,11 +371,11 @@ define KernelPackage/gre
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=GRE support
   KCONFIG:=CONFIG_NET_IPGRE \
-    $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.37)),CONFIG_NET_IPGRE_DEMUX)
+    $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),CONFIG_NET_IPGRE_DEMUX)
   FILES=$(LINUX_DIR)/net/ipv4/ip_gre.ko \
-    $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.37)),$(LINUX_DIR)/net/ipv4/gre.ko)
+    $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),$(LINUX_DIR)/net/ipv4/gre.ko)
   AUTOLOAD:=$(call AutoLoad,39, \
-    $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.37)),gre) ip_gre)
+    $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),gre) ip_gre)
 endef
 
 define KernelPackage/gre/description