make "name" parameter optional in dnsmasq "boot" config sections
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 18 Feb 2009 22:00:36 +0000 (22:00 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 18 Feb 2009 22:00:36 +0000 (22:00 +0000)
SVN-Revision: 14557

package/dnsmasq/Makefile
package/dnsmasq/files/dnsmasq.init

index 06bcbfcce019a59873797539df66eae07b0400d5..3599fa09ade7640db3078c94f52f5f6c708c57ee 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.47
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
index 6cb0e0f4fae8e3b7279276e790ce1dfe64198157..870414900f8007edbefc1a2fc75c7bb5199eded9 100644 (file)
@@ -182,7 +182,6 @@ dhcp_boot_add() {
        local cfg="$1"
 
        config_get name "$cfg" name
-       [ -n "$name" ] || return 0
 
        config_get filename "$cfg" filename
        [ -n "$filename" ] || return 0
@@ -193,7 +192,7 @@ dhcp_boot_add() {
        config_get serveraddress "$cfg" serveraddress
        [ -n "$serveraddress" ] || return 0
 
-       append args "--dhcp-boot=net:$name,$filename,$servername,$serveraddress"
+       append args "--dhcp-boot=${name:+net:$name,}$filename,$servername,$serveraddress"
 
        dhcp_option_add "$cfg" "$name"
 }