brcm63xx: add support for Asmax AR 1004g router
authorJonas Gorski <jogo@openwrt.org>
Sat, 22 Feb 2014 11:16:38 +0000 (11:16 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sat, 22 Feb 2014 11:16:38 +0000 (11:16 +0000)
Support for Asmax AR 1004g router

Signed-off-by: Adrian Feliks <mexit@o2.pl>
Patchwork: http://patchwork.openwrt.org/patch/4464/
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 39674

target/linux/brcm63xx/base-files/etc/uci-defaults/02_network
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.10/558-board_AR1004G.patch [new file with mode: 0644]
target/linux/brcm63xx/patches-3.10/801-ssb_export_fallback_sprom.patch

index 087bce960d056f755feeea07e7494e3b08d0f1a2..b4ab46d56b3c8b4841e3d3a3b932c72bf353da01 100755 (executable)
@@ -28,6 +28,7 @@ SPW500V)
 96338W2_E7T |\
 96348A-122 |\
 96348W3 |\
+AR1004G |\
 CPVA642 |\
 CT536_CT5621 |\
 CT6373-1 |\
index afe96249339b4dd556952ad0faa22dc70c70b9d5..1d9b448b75ae8269d19a5d5a51636133abb9ba61 100755 (executable)
@@ -57,6 +57,10 @@ brcm63xx_detect() {
                brcm63xx_has_reset_button="true"
                ifname=eth1
                ;;
+       AR1004G)
+               status_led="AR1004G:green:power"
+               brcm63xx_has_reset_button="true"
+               ;;
        CVG834G_E15R3921)
                status_led="CVG834G:green:power"
                ifname=eth0
index e0bcb07d61297d6c5cfcfaecbf241545f04d82ce..ecdcecaaa32490179b54023e5c278db20d284548 100755 (executable)
@@ -190,6 +190,8 @@ define Image/Build
        $(call Image/Build/CFE,$(1),96368MVNgr,6368,96368MVNgr-generic)
        $(call Image/Build/CFE,$(1),96368MVWG,6368,96368MVWG-generic)
 
+       # Asmax AR 1004g
+       $(call Image/Build/CFEFIXUP,$(1),96348GW-10,AR1004G,6348,AR1004G)
        # BT Voyager V210_BTR
        $(call Image/Build/CFE,$(1),V210_BB,6348,BTV210_BTR,,--layoutver 5)
        # BT Voyager V210_ROI, V210_WB
diff --git a/target/linux/brcm63xx/patches-3.10/558-board_AR1004G.patch b/target/linux/brcm63xx/patches-3.10/558-board_AR1004G.patch
new file mode 100644 (file)
index 0000000..4fb76ed
--- /dev/null
@@ -0,0 +1,70 @@
+From: "mexit@o2.pl" <mexit@o2.pl>
+Date: Sun, 24 Nov 2013 21:33:38 +0000
+Subject: [PATCH 4/5] brcm63xx: add support for Asmax AR 1004g router
+
+Support for Asmax AR 1004g router
+
+Signed-off-by: Adrian Feliks <mexit@o2.pl>
+---
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -2208,6 +2208,51 @@ static struct board_info __initdata boar
+       },
+ };
++static struct board_info __initdata board_96348gw_10_AR1004G = {
++      .name                           = "AR1004G",
++      .expected_cpu_id                = 0x6348,
++
++      .has_uart0                      = 1,
++      .has_enet1                      = 1,
++      .has_pci                        = 1,
++      
++      .enet1 = {
++              .has_phy                = 1,
++              .phy_id                 = 0,
++              .force_speed_100        = 1,
++              .force_duplex_full      = 1,
++      },
++
++      .leds = {
++              {
++                      .name           = "AR1004G:green:inet",
++                      .gpio           = 3,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "AR1004G:green:power",
++                      .gpio           = 0,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "AR1004G:red:power",
++                      .gpio           = 6,
++                      .active_low     = 1,
++              },
++      },
++
++      .buttons = {
++              {
++                      .desc           = "reset",
++                      .gpio           = 33,
++                      .active_low     = 1,
++                      .type           = EV_KEY,
++                      .code           = KEY_RESTART,
++                      .debounce_interval = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
++              },
++      },
++};
++
+ #endif
+ /*
+@@ -4457,6 +4502,7 @@ static const struct board_info __initcon
+       &board_96348A_122,
+       &board_CPVA502plus,
+       &board_96348W3,
++      &board_96348gw_10_AR1004G,
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6358
index 7ed27a6211bccec4228009a108ed7720963a964b..620bf40021f70adfa7854a578b902beecb5221c1 100644 (file)
@@ -8,7 +8,7 @@
  #include <linux/spi/spi.h>
  #include <linux/spi/spi_gpio.h>
  #include <linux/spi/74x164.h>
-@@ -4499,7 +4500,7 @@ static const struct board_info __initcon
+@@ -4545,7 +4546,7 @@ static const struct board_info __initcon
   * bcm4318 WLAN work
   */
  #ifdef CONFIG_SSB_PCIHOST
@@ -17,7 +17,7 @@
        .revision               = 0x02,
        .board_rev              = 0x17,
        .country_code           = 0x0,
-@@ -4519,6 +4520,7 @@ static struct ssb_sprom bcm63xx_sprom =
+@@ -4565,6 +4566,7 @@ static struct ssb_sprom bcm63xx_sprom =
        .boardflags_lo          = 0x2848,
        .boardflags_hi          = 0x0000,
  };